1

I have an old 13” MBP (Early 2011) which I use regularly but just a few minutes per day.

Today I came back home - MBP was turned on and charging - and keyboard just doesn’t seem to work.

Some keys (A, D, S) do seem to work, but the rest of the keyboard is unresponsive. The very bad sign is that, by pressing J it actually writes stuff like adsssadsa.

  • I couldn’t do any of the standard suggestions (reset PRAM or SMC). The shortcuts just don’t work, so that the machine turns on as if I wasn’t pressing any key.
  • While D works (when MBP is turned on), I was not able to enter the Apple Hardware Test. Any idea why?
  • As read somewhere, I run kextstat -kl | awk ' !/apple/ { print $6 } ‘ to identify problematic apps, but nothing was printed

Now to me this really looks like a liquid damage, but I am more than 100% sure that nothing happened. Could this be explained / solved in some other way, do you have any suggestion, other than going to the closest apple store?

I surely will, but it’s not so close and I’ll be able to go only next week.

  • Could possibly be a swollen battery. Have you tried an external USB keyboard? – Tetsujin Mar 10 '16 at 22:31
  • To just verify if it has got to do something to do with the software or hardware, can try using an external keyboard and let me know – leovarmak Mar 11 '16 at 4:45

You must log in to answer this question.

Browse other questions tagged .