3

Lately Mac app store has stopped showing any updates. It always says 'No updates available'.

Please see a screenshot here.

Screenshot

It doesn't even show about OS installed. Can somebody share a solution to fix this?

EDIT

I can state that something's wrong on the basis of difference between installed version of 'Numbers' in my system and the version available on App store.

  • If you go to Numbers app page in App Store - what is written on the button (for example: app price/buy, upgrade, install). Can you see Numbers in "Purchased" tab? – techraf Mar 9 '16 at 5:02
  • It says 'Open'. And it's listed in Purchased tab. – Shanil Soni Mar 9 '16 at 5:07
  • sudo softwareupdate --list ? – techraf Mar 9 '16 at 5:10
  • That says 'No new software available'. – Shanil Soni Mar 9 '16 at 5:12
  • I am afraid you have to provide more details. Version numbers, if you used other country store, anything else. You might also try to remove and install again some app that you suspect is not being updated. – techraf Mar 9 '16 at 5:29
5

This is a known issue with the fix required of removing your main hard drive from indexing through the Privacy screen. You may have to add the main hard drive to privacy first, then remove it, then restart, and allow the hard drive to be indexed again.

When I have had problems with the App Store, I have found that the boot volume was entered in the System Preferences -> Spotlight -> Privacy pane. If the boot volume is included, it is excluded from the Spotlight indices, and the App Store uses those indices to determine what applications are installed.

Once the volume is removed, and the indices updated (you have to wait...), the App Store started finding updates.

For better technical details, see: Mac App Store: "Cannot update App Store purchases or updates do not seem available" and "Mac App Store Update issue in Yosemite"

1

This StackOverflow link worked for me on resetting the App Store blank screen: How to fix / Reset App Store app on Mac OSX - El Capitan

(Wish I could have just done a comment but not enough rep.)

  • Welcome to Ask Different! Which answer in the link helped you? You may want to summarize the answer here in case it is removed over on SO. Cheers! – bjbk Apr 2 '18 at 18:10
-1

I had this problem on High Sierra. I tried a variety of suggestions: signing in and out, clearing caches, changing time zones, but none of those worked.

For me, booting into Safe boot, and then restarting normally fixed it.

  • Anyone care to explain the downvote they've suddenly applied to a three-year-old post? – benwiggy Dec 20 '18 at 7:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .