1

I have an early-2015 MBP running 10.11.2 and have been having wifi problems on certain networks ever since buying it.

At home, my internet connection will drop every 10-15 minutes - according to the Network menu, I'm still connected to my router, but I get a timeout anytime I try to visit a page. This is not a problem that happens with any of my other devices. I've tried resetting my router and restarting my laptop, to no avail.

My router is a Cisco DPC3825.

Any ideas?

here's the exact error I get in Chrome:

This webpage is not available DNS_PROBE_FINISHED_NO_INTERNET

I should add - despite the error - this is not a DNS problem, I've tried various DNS server combinations and none have helped.

Furthermore,my laptop doesn't want to connect to any wifi that requires browser-based authentication - e.g., ShawOpen and Starbucks networks. Not sure if this is related to the other issue but it's still irritating.

1

WiFi problems have been a constant problem with OS X over the past few releases. El Capitan is supposed to have fixed them, but problems still persist.

Fortuntaley, there is a fix and it invloves trashing your wireless setttings and starting again from scratch. OS X Daily has a good write up on how to accomplish this.

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Tetsujin Mar 9 '16 at 7:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .