1

The button "Use your apple ID ..... " doesn't work on her phone on iMessages settings, but she entered her phone number properly to be used for iMessages. I tried turning on and off the iMessages. Still doesn't work and she is sending me SMS regular instead of iMessage iPhone to iPhone. I even managed to send her iMessage from Macbook to her iPhone 4 using Message app for Macbook, but not from iPhone 5 (I have iPhone 5). But Apple, (please) this is the BASIC BASIC function of a telephone, why can't you fix this......I love Apple and all but things like this make me freaking jump out of my skin....the simplest basic stuff :)

  • How is your iPhone 4 connected to the Internet when you experience this problem? Through Wi-Fi or through the phone network? What is the quality of the network used? – dan Mar 16 '16 at 22:00
  • The turning on of iMessage depends only of the time to authenticate the sender on Apple Servers through Internet. If your Internet connection is through the phone 2G network, this process will take a few minutes. If your connection is through a Wi-Fi network arriving to a Box which is fully loaded with a streaming download, this process may take a quarter of an hour. – dan Mar 16 '16 at 22:04
  • Turning on and off Messages > iMessage won't accelerate this process, as triping up someone who walks slowly will not improve his speed. – dan Mar 16 '16 at 22:10
1

I'm with you, this pisses me off. This small explanation may help:

iMessages on an iPhone has two ways of sending a text.

iMessage

This is the blue colored bubbles. It requires data to be turned on to send and receive messages. It goes through apple servers. This can be sent between macs, iPads, iPods, and iPhones.

SMS

This is the green colored bubbles. It does not require data and it goes through cell towers from your carrier. This can only be sent to phones, including android phones, those old Nokia phones, and anything that can receive text messages. It does not send to a mac, iPod, and iPad without cellular

On an iPhone you can have both enabled, or just SMS. You cannot disable SMS.

  • iPhone can relay text messages to and from the other devices. It is possible to disable sending iMessages as text messages. – Thorbjørn Ravn Andersen Mar 17 '16 at 7:19
  • How? I couldn't find it. – Jersh Mar 17 '16 at 15:08
0

iMessage can be frustrated sometimes especially when the sudden error happen between connection. Were you able to confirm and activate the iMessage? Sometimes, this will take awhile or it may just not work at all.

I don't know specifically which solutions to give you, but this guide might be able to help.

  • It worked out itself actually for me, after some trying and spending money on SMS-s. Finally, it hooked to wifi and started sending iMessage-s properly instead of SMS< when hooked onto a wifi. – Vladimir Despotovic Mar 20 '16 at 2:40
-1

Happens to me as well. One time I sent a message to my friend on iPhone 6 from an iPhone 5 and it sent SMS one time and after 5 minutes it sent it as iMessage. All the time we were both on my local fast Wi-Fi (30 Mb/s) which is 2 metres far (the router is 2 meters far). Not sure how to resolve but resetting iMessages again might do the trick.

  • Sometimes this work, until a better answer arrives, I will accept this one as a good answer. – Vladimir Despotovic Mar 8 '16 at 22:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .