2

In attempting to upgrade from OS X 10.6.8 to El Capitan I've run into a bit of stalemate. The installation is unable to complete(indeed, it seems to barely commence) due to issues "verifying or repairing" the file system, and attempts to reboot to the original OS on the HD are unsuccessful as "Startup Disk could not gather enough information on the selected disk".

The most common answer I've seen to this issue is to reboot into recovery mode, check the HDD for errors, repair the device and/or clone all the undamaged data on the disk to a secondary drive and boot from there. Unfortunately this wasn't working as I tried it, and running diskutil in the terminal revealed this was due to the lack of any recovery disk on the drive. I've also attempted to boot into internet recovery(which an article mentioned was the default path for "Cmnd+R" if a recovery disk was not found) which didn't work, though I'm not totally sure my machine(an iMac11,3) supports this option as I've heard conflicting dates as to when this feature was introduced(2010 and 2012).

Through some small miracle I've tracked down the original OS X 10.6.3 installation disc that was shipped with my computer, and I've been attempting to boot from that to do a fresh installation of the original OS. The alternate start-up disk command, "C", is the only startup command that has done anything to disrupt the normal boot-up sequence into the Capitan install, but it hasn't gone past delaying said boot-up so long as I am physically holding down the key. Numerous attempts to get the 10.6.3 DVD into the drive have been pretty unsuccessful: the drive accepts it, does a little bit of reading, then spits it right back out again without any apparent change to the system state or available disc information. I've tried inserting the disc on startup both with and without attempting to enter the alternate startup command, subsequent to the failed 10.11 installation, in the installation's terminal function, and just prior to a system shutdown in attempts to get the system to at least hold onto the disc through the next boot cycle so that it might be used as an alternative resource.

Right now my main goal is just regaining functionality on my computer, honestly I'm not even too interested in jumping to EC just yet and would prefer to upgrade through Yosemite or Mavericks first, but thanks App Store. Important files on the HDD have all been backed up(so wiping the HD isn't devastating, but also not preferable), though the backup is not a Time Machine copy so doesn't have the system recovery functionality. The external HD they're backed up on has about 2TB of space available so there is free space to move data for disk repair/recovery, however it is not HFS formatted(thus no Time Machine), and reformatting is not an option.

If anyone has ideas on how to recover the OS currently installed without the various recovery start-up options, or downgrade slightly to the installation disc version they would be greatly appreciated! Alternately, if you have an idea for getting 10.9 or 10.10 using a USB-installation that would be nice too, as ultimately that's where I need my system to end up.

Thanks

Edit I tried copying the 10.6.3 installation disc onto a USB drive using a Windows computer, in doing so found out that the disc features a remote installation program allowing me to use the window's optical drive to read the disc over Ethernet to the troublesome Mac. Attempted to follow that setup, and successfully entered Startup Manager with the Alt startup command, but the only available disk it showed was the 10.11 installation on the local HD, and neither the original OS on that drive nor the networked installation disc.

  • just for info - Booting to a Recovery partition or Internet Recovery was dependant on you already being on 10.7 & having installed a firmware update - support.apple.com/en-gb/HT201314 & support.apple.com/en-gb/HT202313 – Tetsujin Mar 8 '16 at 6:51
  • Yeah, found that out later on yesterday, though curiously I did find a post from someone running 10.6.8 who accidentally found themselves in Internet Recovery mode. The firmware update that allows for Internet Recovery was back-compatible with 10.6.8 so installing created an IR function without creating a recovery partition as anything past 10.7 would have. I was up to date on everything except Safari and iTunes so perhaps thats there, furthermore I've been using a bluetooth keyboard and may have been hitting Cmnd+R too soon, going to try it once my drive finishes backing up. – Jokyo Mar 8 '16 at 23:37
  • Ahh, yes. I'd definitely try borrowing a USB keyboard to eliminate that possibility – Tetsujin Mar 9 '16 at 9:20

You must log in to answer this question.

Browse other questions tagged .