I try to mount a SMB share in Finder but I have two problems.

  1. The time for mount is about 25s.
  2. Folder listings; very slow when there are many elements inside.

The smb share is ending by .local. I know that this create a conflict with the Mac's Bonjour zero-configuration networking service but I can't chance my domain.

The others stations running on Windows 7 are working very fast.

Does it exist any solution to mount and list quickly?

The problem is caused by Apple's home made implementation of the smb protocol. Using smb3 won't make a difference.

Server-Side Fix

If you have control of the smb server (Samba?) then you can fix this issue by enabling the vfs_fruit module. If you are not using Samba then you'll need to find another way to enable "Alternate Data Streams" (ADS) and intercept OSX's "special" streams: AFP_AfpInfo and AFP_Resource. I made notes of all the details at the plazko.io blog. On Samba server you can fix the issue by enabling vfs_fruit in smb.conf like this:

vfs objects = fruit streams_xattr

Client-Side Fix

If you do not have control of the smb server, then your only option is to change the way your OSX client is handling smb. The only way to do that is to replace Apple's implementation of smb with Samba. I have never done this, but there is a tutorial here.

This is an excerpt of the answer I gave to Slow SMB connection Buffalo Linkstation.

You are correct that mDNS may be causing the issue (I see DNS conflicts create network bottlenecks all the time at work). You can turn mDNS (and bonjour) by looking here. If you need Bonjour for something, things will get more complicated.

  • Hello, If I follow this, could I lost the internet conexion? Thank you – Eduard Mar 8 '16 at 18:56
  • Hello, I tried this command and my internet conection and the local network don't work : ( Does it exist any other fix? Thank you – Eduard Mar 8 '16 at 20:11
  • Hmmm... That shouldn't have caused a total network loss. I'll take a look to see if anything in those instructions could have caused that – agentroadkill Mar 9 '16 at 6:06

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.