1

I attach pen-drive to my Macbook-air. It is detecting and I can also copy from my pen-drive to my Hard disk. But I cannot copy data from Hard disk to pen-drive. I tried with different pen-drives, but got the same result.

What could be the reason for that? I have searched on web a lot but cannot know the reason.

Thanks in Advance !

  • 2
    How are the pen drives formatted? If they are all formatted NTFS, this would be the expected behavior. – David Anderson Mar 7 '16 at 7:00
  • 1
    Is your Pen-drive formatted on FAT32 and are you trying to copy a really big file (>4GB) onto it? – EDP Mar 8 '16 at 6:03
1

OS X is not intended to do this out of the box, it doesn't work with FAT32 and NTFS, which are wide spread file systems on USB Stick Drives, especially on Windows.

  1. The solution which works like a charm for myself is to use Virtual Machine on Mac, with Windows 10 installed. I'm using Parallels Desktop, because of speed and tight integration with Mac. But there are also other options, alike VMWare or VirtualBox.

  2. If you don't like the idea of having Windows virtualized, you may try to use standalone software, which is intended for mounting NTFS drives:

As @NetherLinks outlined in the comments, FAT32 may also work on Windows, if you'll do the simple trick. Read below.

The Disk Utility advanced options of El Capitan are hidden and you needed, first:

  1. Quit Disk Utility.
  2. Open the Terminal utility.
  3. Run the following Command:

    defaults write com.apple.DiskUtility advanced-image-options 1

  4. Relaunch Disk Utility

And now, just format your USB with MBR Partition (Master boot record) and exFAT file System.

The USB now can mount in OSX & Windows.

  • 5
    FAT32 is supported by OS X natively, both read and write. – NetherLinks Mar 7 '16 at 13:15
  • You are welcome! I knew it, because faced the same problem, and did investigation. Was really annoyed it doesn't work out of the box on Mac, but it does on Linux distributes, alike Ubuntu. – Farside Mar 7 '16 at 13:17
  • @NetherLinks, you may post separate answer, if you want to show your knowledge. Don't forget to specify which version of OS is that. – Farside Mar 7 '16 at 13:19
  • Actually @NetherLinks, you are right. I will extend my answer. It works, but with some tricks in settings. By default FAT32 formatted by OSX El Capitan, will not be readable on Windows. – Farside Mar 7 '16 at 13:23
3

The drive is probably NTFS, and OS X can't write to that. Either reformat it as FAT32/ExFAT using Disk Utility, or use an app like http://www.tuxera.com/products/tuxera-ntfs-for-mac/.

The current top-rated answer is incorrect about OS X not being able to write to FAT32 partitions.

1

Follow these steps to format the USB drive to be able to copy files to it from a Mac:

  1. Open Disk Utility app. The quickest way is search on Spotlight and click the result under TOP HITS. Alternatively, you can access it via Finder → Applications → Utilities → Disk Utility.

  2. In the sidebar under External section, highlight your flash drive. Note: right below your device name, it also shows information about the drive e.g. size, file system, etc. In my case, I can see it's a 32 GB volume in MS-DOS(FAT) file system.

  3. Now click the Erase button in the toolbar. In the new pop-up window, choose the format to be exFAT. You may also change the device name if you want. Then hit the Erase button to continue. Kind reminder: make sure you have backed up the data before you do this.

  4. Wait until the erasing process to complete. It should be very quick (only a few seconds to format my 8 GB SanDisk drive).

  5. This step is optional. I'm showing this to verify that the USB drive has been reformatted to the file system I wanted. I saved several files to the disk, and open Disk Utility again. And yes, it's now with the exFAT file system.

Source:

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .