0

I can't run Eclipse on Macbook on Yosemite: "Version 1.6.0_65 of the JVM is not suitable for this product." and I have Java 1.8. When I open settings I can see that version of Java is 1.8

  • Please include the version of your Eclipse, as well as the output of running java -version on Terminal. – NetherLinks Mar 6 '16 at 0:36
  • Currently? Now I have this: -bash: java: command not found Eclipse PDT is: eclipse-php-mars-2-macosx-cocoa-x86_64(1).tar.gz – Vladimir Despotovic Mar 6 '16 at 0:54
  • Did you install JDK 8 from Oracle? – NetherLinks Mar 6 '16 at 0:56
  • Yes. I did. Yes. – Vladimir Despotovic Mar 6 '16 at 1:05
  • When I run java -version I get the proper java version too (1.83): java -version java version "1.8.0_73" Java(TM) SE Runtime Environment (build 1.8.0_73-b02) Java HotSpot(TM) 64-Bit Server VM (build 25.73-b02, mixed mode) (I edited .bashrc for PATH to point to proper java version) – Vladimir Despotovic Mar 6 '16 at 1:16
2

It has worked for me to change inside info.plist

<key>JVMVersion</key>

from <string>1.6*,1.7+</string> to <string>1.8*,1.6*,1.7+</string>

and inside ./bin/idea.properties change JVMVersion=1.6* to JVMVersion=1.8*

1

Finally this worked for me. Add this line to the .plist inside Eclipse application Contents subfolder with version of jdk you want to use: -vm/Library/Java/JavaVirtualMachines/jdk1.8.0_73.jdk/Contents/Home/bin/java

  • I was just trying that and that actually solved the problem! Thanks! – Vladimir Despotovic Mar 6 '16 at 2:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .