1

I have a Late 2011 MacBook Pro and I just got it back from the repair shop (mainboard was swapped). I immediately installed OS X El Capitan (before it was Yosemite) and found that when I closed the lid, the Mac would not go to sleep anymore. Even testing in other user's accounts and after restarting, resetting NVRAM and SMC and even booting from a different hard disk (with OS X Lion installed), it won't go to sleep and also the little LED on the right will not light up, neither while booting nor when I close the lid. Running pmset -g assertions in Terminal gave this output:

Assertion status system-wide:

   BackgroundTask                 1

   ApplePushServiceTask           0

   UserIsActive                   1

   PreventUserIdleDisplaySleep    0

   PreventSystemSleep             1

   ExternalMedia                  0

   PreventUserIdleSystemSleep     0

   NetworkClientActive            0

Listed by owning process:

   pid 54(configd): [0x00000054000701d1] 00:02:13 DenySystemSleep named: "InternetSharingPreferencePlugin" 
   pid 102(hidd): [0x0000001e000901ba] 
00:03:07 UserIsActive named: "com.apple.iohideventsystem.queue.tickle" 
    Timeout will fire in 894 secs 
Action=TimeoutActionRelease
   pid 44(UserEventAgent): [0x00000030000b01cd] 
00:02:48 BackgroundTask named: "com.apple.mds.0" 
    Created for PID: 64. 
   pid 44(UserEventAgent): [0x00000006000b0137]
 00:03:30 BackgroundTask named: "com.apple.metadata.mds.power" 
    Created for PID: 64. 
Kernel Assertions: 0x100=MAGICWAKE
   id=501  level=255 0x100=MAGICWAKE mod=01.01.70, 
07:30 description=en0 owner=en0
Idle sleep preventers: IODisplayWrangler

I have prevented bluetooth devices from waking the Mac, but otherwise I am not sure what to do. Could it be a hardware issue caused by the replacement of the motherboard?

  • It will automatically go to sleep though after the set time (15min – zero Mar 5 '16 at 21:31
  • Perhaps the lid sensor was damaged by the mobo replacement? – uint128_t Mar 5 '16 at 21:40
1

This is looking like a hardware problem. It's possible that the repair shop may have hooked it up incorrectly (even professionals make mistakes) such that the lid closing doesn't register, or the connection may have been knocked out of place.

  • Okay, this sounds plausible. I really tried everything, but it does seems like a hardware problem to me to. Just wanted to make sure if there are any more things I could try before returning it to the repair shop. Thanks a lot! – zero Mar 5 '16 at 21:44
  • I mean, it could be the update, but considering the fact that it can sleep by other means and the computer was recently opened up, it seems like the more plausible possibility to me. – diplomaticDeveloper Mar 5 '16 at 21:46
  • It seems so too. Especially considering that I even tried booting from another harddrive with OS X Lion installed and the issue persisted. – zero Mar 6 '16 at 10:39
0

Im actually finding this issue as well after having upgraded to El Capitan on my Macbook air 2011 11inch. I think this is software related. It doesnt happen every time. When it does go to sleep it takes ap to 30s to a min to wake up.

Theo

  • Rather strange. Have you tried resetting NVRAM and SMC? Also, I tried booting a different harddrive with OS X Lion installed and the issue persisted. I don't know, how deep this software issue goes. Just sending the laptop to sleep and waking it works flawlessly though! – zero Mar 9 '16 at 5:43
0

In your specific case it tells you--- DenySystemSleep named: "InternetSharingPreferencePlugin"

so go to your sys preferences -sharing and turn OFF (uncheck) Internet sharing !

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .