On http://repl.it, I accidentally created an infinite loop in Python 3. I tried to close the tab, but Firefox already stopped responding. It wouldn't respond even after a while, so I force quitted FF. Then, I tried to reopen it, and it bounced for a while. It wouldn't reopen, so I force quitted and reopened again. Now, it is just sitting on my Dock with the little black "open" dot below it. Clicking on the icon does nothing.

How can I fix this? (I hate Safari) I don't mind using Bash/Terminal, if it makes a difference. Also, it would be nice if it didn't reboot all my other apps as well, but if worst comes to worst, this is okay. Thanks!

2 Answers 2


A few things you can try (ordered by "assertiveness"):

  • Start with Command-Option-Escape to bring up the Force Quit dialog and see if it's there. If it is, force quit it (sounds like you've already tried this).

  • Open Terminal, and run ps -eaf | grep Firefox. If Firefox appears in the list (note that there will always be an entry for grep Firefox, this is not what you want, the actual Firefox will be listed as something like /Applications/Firefox.app/Contents/MacOS/firefox), note the PID (the second column, a number), and run kill -9 <PID>.

If neither of these work, try restarting the Dock (maybe Firefox actually isn't running but the Dock is confused):

  • Use the same ps -eaf | grep Dock.
  • There should be a process called /System/Library/CoreServices/Dock.app/Contents/MacOS/Dock, note the PID and run kill <PID>.
  • The Dock should disappear momentarily and then restart.

If all this fails, easiest thing to do is probably just reboot your machine. If the usual shutdown dialog fails, press and hold the power button until the computer powers down.

  • With the second test, I got: 501 56821 56296 0 2:42PM ttys000 0:00.00 grep Firefox Are any of these right?
    – AAM111
    Mar 5, 2016 at 19:55
  • If that's all you got, that means that Firefox isn't running. Try restarting the Dock.
    – uint128_t
    Mar 5, 2016 at 19:56
  • ps -eaf | grep Dock: 501 248 1 0 31Jan16 ?? 2:26.03 /System/Library/CoreServices/Dock.app/Contents/MacOS/Dock 501 300 1 0 31Jan16 ?? 0:07.82 /System/Library/CoreServices/Dock.app/Contents/XPCServices/com.apple.dock.extra.xpc/Contents/MacOS/com.apple.dock.extra 501 456 248 0 31Jan16 ?? 1:23.62 /System/Library/CoreServices/Dock.app/Contents/Resources/DashboardClient.app/Contents/MacOS/DashboardClient 501 56944 56296 0 2:58PM ttys000 0:00.00 grep Dock
    – AAM111
    Mar 5, 2016 at 20:00
  • What is the process id?
    – AAM111
    Mar 5, 2016 at 20:00
  • It's the first line (note the path), so the PID is 248.
    – uint128_t
    Mar 5, 2016 at 20:01

Ok so I had this, if you hit command option and escape, you can cut all power to it!!! This is the best way for me atleast, thanks thiugh


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .