When I enter a string that matches part of the name of an application on Mac, the OS X Spotlight search feature will suggest apps for me to launch. This works for every app except one: Mathematica:

enter image description here

While the string is recognized (presumably from my history) the application is not suggested, and the only way to launch it is directly from the Finder or some other awkward workaround.

Why would — indeed how could — a single lone application behave differently in this regard? How can an application hide itself in this way from Spotlight?

And most importantly: what can I do to restore this standard piece of functionality?


Note that this problem is unique to Mathematica. For example for JetBrains apps, I get:

enter image description here

Moreover, it extends to the Finder itself. For example if I search there I get

enter image description here

even though Mathematica is clearly there

enter image description here

I can reproduce this (for Mathematica only) by simply updating (download, open the DMG, drag the new version to the Applications folder, replace). This is indeed unique to Mathematica (in my experience). I update at least one app a day in this or similar ways, and none of them vanish as a result from Spotlight; only Mathematica.

  • 1
    What happens if you explicitly exclude the app, via drag and drop, into System Preferences > Spotlight > Privacy and then close/reopen and remove the app. Does it now appear in Spotlight? – user3439894 Mar 4 '16 at 15:34
  • @user3439894: Yes! That seems to work! – orome Mar 4 '16 at 15:58
  • Not sure what caused the issue with that particular app however I was hoping that flipping the bit, so to speak, would allow it to be seen. Let us know if it disappears again. – user3439894 Mar 4 '16 at 16:32
  • The problem has resurfaced following the "upgrade" to version 11. – orome Aug 16 '16 at 19:39
  • The issue continues with 11.3. – orome Mar 11 at 15:35
up vote 43 down vote accepted

While this does not directly answer as to why that particular app does not appear in Spotlight, nonetheless as a workaround, try the following:

Explicitly exclude the App, via drag and drop from Finder, into System Preferences > Spotlight > Privacy, and then close/reopen Spotlight preferences and remove the App by selecting it, then click the minus button [-] at the bottom left of the list window.

The App should now appear in Spotlight, however it may disappear again if the root cause is triggered again.

  • This seems to work. I'll keep an eye on it and be back if the problem reappears (e.g., following an update of the app). How this occurred remains a mystery though (and how Wolfram managed to accomplish it when no other app in all the years I've used a Mac — and all the hundreds of apps I've used — has shown this odd behavior)! – orome Mar 4 '16 at 16:41
  • The bug reappeared (again, uniquely to Mathematica) with the "upgrade" to version 11, and this fixed it again (for now). – orome Aug 16 '16 at 19:41
  • @raxacoricofallapatorius, As I do not use Mathematica I'm unable troubleshoot the root cause of this issue. Lets hope that flipping the bit, so to speak, continues to work as a workaround until the root cause is determined and fixed on the developer's end. (That is of course assuming this issue isn't unique to your system and is a reproducible issue on other systems too.) :) – user3439894 Aug 16 '16 at 20:00
  • 2
    Seems like some app updates cause spotlight to not recognized the newer versions. This is a great easy fix though! – Fydo Oct 17 '16 at 19:23
  • 3
    I've seen this issue recently with Slack and Radio Paradise (third-party App Store apps) on macOS 10.12.4. There seems to be a bug in the way App Store updates apps that triggers this failure to be indexed in Spotlight, but only sometimes. If this issue affects you, I strongly recommend sending a bug report to Apple via their feedback form. – Jason R. Coombs May 11 '17 at 10:58

I was facing the same issue with Todoist and Microsoft Outlook. The answer above didn't solve the problem for me on MacOS Sierra 10.12.6, as you can only exclude whole folders now in the Spotlight Privacy tab. I tried that, but it didn't help. However a similar solution worked for me:

  1. System Preferences > Spotlight > Search Results
  2. Untick 'Applications'
  3. Close the settings
  4. System Preferences > Spotlight > Search Results
  5. Tick 'Applications'
  • fwiw, this did not work for me but the accepted answer did. – steel Aug 3 '17 at 19:08
  • 1
    This worked for me. – CoderSpinoza Aug 24 '17 at 2:06
  • Didn't work for me. Skitch disappeared and I can't get it back – vault Mar 14 at 12:37

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.