I often run into the situation where the OS will suspend some of my apps because of low memory. If I am lucky, a window will appear that allows me to select which apps I want to quit and which apps I want to resume, which works reliably and is fine. However, often that window does not appear. This is usually the case when my machine (mid-2015 MBP 15", 16GB RAM, OS X 10.11.2) has just woken from sleep. In that case, the only symptom is that I have a bunch of unresponsive apps that show as (Not responding) in Activity Monitor.

I have tried to resume processes by sending the CONT signal (either via Activity Monitor or via the Terminal) and for a small number of apps this works, but for the majority of apps it does not. For example, when this happened to me just now, I force quitted Preview (which was the chief memory hog) and tried to resume the other apps with CONT. This worked fine for Clear, but not for anything else. In some cases, such as Emacs, it had no effect - process still shows as (Not responding). In other cases, such as Bibdesk, it leaves the app in a strange unusable state where the main window refuses to appear on screen and the menus don't work.

So how can I force that process management window to appear, or otherwise do whatever magic it is doing to "resume" apps?

  • 1
    hopefully, this can get you some insight: apple.stackexchange.com/questions/226201/… in any case, today is the first day i see this weird "resume" window you talk about. to me, the culprit was the console app opened for too many days. still no clue on how to make the "resume" window appear, though. nor do i think it does anything more than sending a CONT signal to apps. are you implying that it actually do?
    – cregox
    Commented Jun 17, 2017 at 21:56
  • 2
    Yes, I suspect that the "Resume" button did more than just send a CONT signal. For instance, I had successfully used it to bring Emacs back to life on several occasions from a "(Not responding)" state, whereas I have never been able to do that with the CONT signal. However, I haven't been bitten by the suspended apps problem in a long time, so I have no way of testing it. They seemed to have fixed the memory leak in Preview.app with a software update :)
    – deprecated
    Commented Jun 19, 2017 at 15:58
  • @deprecated, I'm agree with u. After kill -CONT -c "Google Chrome", Activity Monitor tells me Chrome is normal, however, Command-Option-Esc, Force Quit Application dialogue tells me Chrome is paused.
    – DawnSong
    Commented Sep 12, 2017 at 3:01

3 Answers 3


More googling revealed that the process management window I am looking for is the "Force Quit Applications" dialog, and that it can be easily accessed from the Apple () menu or with the keyboard shortcut Command Option Escape. In normal use, this only has a Force Quit button, but it should also have a Resume button if the system suspends any of my processes again (although I can't directly test this at the moment).

  • 3
    For me "Resume" is only in the version of this dialog after my system has force-paused some apps. Not when I open it myself. But I think paused applications are the same thing as when you hibernate your computer. The application session (ram) is written to disk, so if you force quit the paused apps, the next time you start the app they continue from there. I'm not entirely sure, but I did read some in order to understand this and it also behaved that way for me.
    – Albin
    Commented Dec 21, 2016 at 11:25
  • how is this an answer, though?
    – cregox
    Commented Jun 17, 2017 at 21:56

I encountered this same issue. THe CONT signal did not work and there was no Resume button on the Force Quit dialog. I did not want to force quit the app, because I would lose my work. Here is what worked for me:

I sent a STOP signal through Activity Monitor and the app resumed, in this case word, and popped a dialog asking if I wanted to save my work. I selected cancel and began using the app as normal.

  • +1 for suggestion to use Activity Monitor to send STOP to process. Launch Activity Monitor, select the mishehaving app, and go to View > Send Signal to Process... in the menu bar. Select Stop (SIGSTOP) from the dropdown and click send. For me, this un-paused the app and allowed me to save/close open windows and quit the app gracefully. Commented May 9, 2018 at 20:01

kill command with -CONT option will resume an application. More details

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .