1

I'm following this guide to install OpenMPI on my Mac. I think everything is going well, but now I'm at the step where I have to make all. When I try, I get the error Agreeing to the Xcode/iOS license requires admin privileges, please re-run as root via sudo., so I can't go further.

EDIT: looking at the downvoted answer here I tried to run Xcode and say ok to license agreement. Now, when I enter make all I get the error in the following figure

screenshot

Indeed, I see there's no file named makefile (only Makefile.* files are present).

I don't know why but a second ./configure --prefix=/usr/local solved the problem of make all, which is currently in execution. Maybe the license agreement should have been done before this step.

  • There is no need to delete the question. You may answer the question yourself! – klanomath Mar 3 '16 at 12:22
  • 1
    Yes the license agreement was required first. confgure calls the C compiler and the first run would have reported errors. – Mark Mar 3 '16 at 12:22
0

I find the solution to my problem. The the license agreement was required to be completed before ./configure --prefix=/usr/local (as I suspected and @klanomath confirmed). If not so, the command make all can't be run.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .