I turned on my Mac one day and found that Alt + 3 no longer types a hash (#) symbol, but types a pound (£) instead.

I’ve checked the keyboard input source in System Preferences and it’s set to U.S. (which is to be expected). I’ve also found I can type a hash symbol with Shift + 3, but this is undesirable as I’m a website developer, use hashes frequently, and it’s in my muscle memory to hit Alt + 3 for a hash.

What would affect this?

  • 3
    That's the US way round. UK has £ on shift & # on alt. UK vs US
    – Tetsujin
    Mar 2 '16 at 11:46
  • Shift-3 is # on all except UK keyboards so you need to chnage back to UK settings
    – mmmmmm
    Mar 2 '16 at 11:55
  • @Mark I think this should be an answer, not a comment.
    – Brick
    Mar 2 '16 at 12:17
  • Switching to British has indeed solved it! Mar 2 '16 at 12:22

The only keyboard layout that has Alt3 as hash # is the one called British: all others have Shift3

So you need to change the input source to British.

Note most developers have the opposite issue and want to match US and all Windows and Unix keyboards to have Shift3 as #

  • It is also available for Irish keyboard layout.
    – Ram Patra
    Jun 6 '19 at 15:30

I just had this issue and despite having a British iMac with a British keyboard the OS seemed to have removed British keyboard type from the settings in System Preferences > Keyboard > Input Sources. You can re-add the correct keyboard type from that location with the + button.

I believe this must have happened during an update to El Capitan or Sierra as it was present and active when I first bought the iMac - this may happen to other Macs not set to U.S. keyboard.


I also had this problem. My machine decided to change my keyboard settings following an update. I normally have British and Greek on the menu bar dropdown (Greek for easy access to greek characters for scientific symbols now and then). Both disappeared recently to be replaced by USA. I also have muscle memory for £ and # as alternative '3' characters.

It was easily fixed by opening keyboard preferences and using + to add British and Greek and - to remove USA.


I went into Input Source, then I deleted the ABC Extended option leaving just the British option, and that solved it straight away.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .