Ever since my transition to 10.10.5 Yosemite, quick look keeps corrupting the preview images every now and then. Sometimes is persists until reboot, other times it goes away after a while. The image files themselves are fine and open and display in any application.

Any ideas?


enter image description here

  • Why not update to El Capitan? That ought to fix this. Commented Mar 2, 2016 at 13:15
  • @RedEagle2000 How?
    – JMY1000
    Commented May 26, 2016 at 15:12
  • @JMY1000 Go to the Mac App Store and you should see somewhere it says "Update to El Capitan", then just download it and follow any on-screen instructions. Commented May 26, 2016 at 15:17
  • @RedEagle2000 Not what I meant :P I meant how would it fix the issue?
    – JMY1000
    Commented May 26, 2016 at 20:43
  • 1
    @RedEagle2000 Fair, but "Upgrade the OS" doesn't solve everything, and if they need/want to stay on 10.10, the question is still valid, as other 10.10 installs don't appear to have this issue.
    – JMY1000
    Commented May 26, 2016 at 20:46

2 Answers 2


Create a guest Account

and test if the problem still persists. To activate the guest account use the following steps:

  • Open System Settings Users & Groups, click on the lock below to unlock it and type your password.
  • On the left panel you see the Guest Account, activate it and log in and test.
  • Deactivate it if you're done.

Repair disk permissions with disk utility

Sometimes files are corrupt and can be repair using the disk utility.

  • Click on the Finder Desktop and then press the keys Command + Shift + G
  • Insert the following path into the small window and hit Enter to open the location:


  • Open Disk Utility and choose on the left panel your System drive.

  • Click on First Aid (El Capitan) or below the buttons check & repair (Yosemite and below) to repair disk permissions. Restart and test if the problem still exists.

Try to reset the quicklook cache

Open Terminal (you find it in the utilities folder - see location above), and type the following commands:

qlmanage -r
qlmanage -r cache

After this is done you need to move some files to your desktop.

Open the following path location and move the files marked bold to your Desktop. Click on the Finder Desktop and press Command + Shift + G and insert the following path in the window:


Move the following files to your Desktop:


Restart and Test

Check for Hardware Issues

To see if there isn't a Hardware Problem restart your mac and press the D key during startup.

  • It remains a problem, and to add to it, the cached previews are actually fine. It is the full screen generated ones that are scrambled every now and then.
    – Maurits
    Commented Jun 1, 2016 at 21:08
  • I'm going to accept this answer, because resetting the quicklook cache, does help, most of the time.
    – Maurits
    Commented Jun 2, 2016 at 21:44
  • Sometimes the copy & text selection feature in Quicklook break the preview images. The defaults command works in Yosemite and earlier Versions. Unfortunately this feature was removed from El Capitan. So I don't write down im my Answer. You can try to disable it in Yosemite and try if works. But remember you loose the ability copy and select text. Here the command you should type in your Terminal: defaults write com.apple.finder QLEnableTextSelection -bool FALSE; killall Finder . To Enable replace FALSE with TRUE.
    – dante12
    Commented Jun 4, 2016 at 6:58

This may help : http://encase-forensic-blog.guidancesoftware.com/2014/05/examination-of-mac-os-x-quick-look.html or https://discussions.apple.com/thread/1289781?tstart=0

You should be able to rebuild the so called ThumbnailCache on your mac. This should work. hope this helps :)

  • Also try relaunching the finder in the force quit menu.
    – Nate
    Commented May 26, 2016 at 4:31
  • Welcome to Ask Different! Please refrain from posting link-only answers. Links can change over time and questions and answers will lose their context. You can see How to Answer for info on how to provide good answers. - From Review -
    – fsb
    Commented May 26, 2016 at 5:33
  • @Nate, sorry but relaunching the finder doesn't help.
    – Maurits
    Commented Jun 1, 2016 at 21:03
  • Sorry it didn't work. I'll tell you if I find out any thing else on the issue.
    – Nate
    Commented Jun 2, 2016 at 4:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .