Today I noticed the QuickLook feature stopped displaying .jpg, .png, and .pdf file previews. Desktop icons for these types don't show thumbnails. Pressing SPACE with the file selected in Finder just shows the iconic type of file it is.

And I've tried the CNET recommended fixes:

  • qlmanage -r
  • qlmanage -r cache
  • checking in /Macintosh HD/System/Library/QuickLook/, /Macintosh HD/Library/QuickLook/, and ~/Library/QuickLook/
  • removing the files called com.apple.quicklook.ui.helper.plist, com.apple.quicklookconfig.plist, and com.apple.QuickLookDaemon.plist

Other QuickLook file types work well.

At first, it looked like the control was taken over by Lytro:

2016-02-29 17:53:52.461 qlmanage[2351:64583] [qlinfinite] Instantiated plugin in host with identifier (null)
2016-02-29 17:53:52.461 qlmanage[2351:64583] [qlinfinite] Found 61 system generators
2016-02-29 17:53:52.462 qlmanage[2351:64583] [qlinfinite] Registered generator CFBundle/CFPlugIn 0x7f96e9818e00 </Applications/Lytro.app/Contents/Library/QuickLook/LytroLFR.qlgenerator> (bundle, loaded) for type public.jpeg

Reinstalling the new Lytro desktop, things changed.

More disturbing was this... Dropbox seems to be taking control:

$ qlmanage -m plugins | grep -i public.image
  public.image -> /Applications/Dropbox.app/Contents/Library/QuickLook/DropboxQL.qlgenerator (2)

Creating a new account on my Mac shows things working fine. So it has to be something about my configuration ...except that I have no ~/Library/QuickLook directory, and I also do not have any ~/Library/Preferences/com.apple.[Qq]uicklook* entries either.

At this point, multiple reboots, even with Safe Mode do not resolve the issue.

Is there a way to reset the QuickLook associations back to default?

Also, could someone post their qlmanage -m plugins output from a working system?

More weird, previewing via the command line using qlmanage -p anyimagefile.jpg from the Terminal works just fine!

That said, it does emit this cryptic error:

2016-02-29 19:10:41.835 qlmanage[3873:130464] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0x8f03, name = 'com.apple.coredrag'
See /usr/include/servers/bootstrap_defs.h for the error codes.
2016-02-29 19:10:42.028 qlmanage[3873:130464] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0xbb37, name = 'com.apple.tsm.portname'
See /usr/include/servers/bootstrap_defs.h for the error codes.
2016-02-29 19:10:42.029 qlmanage[3873:130464] *** CFMessagePort: bootstrap_register(): failed 1100 (0x44c) 'Permission denied', port = 0xbc1b, name = 'com.apple.CFPasteboardClient'
See /usr/include/servers/bootstrap_defs.h for the error codes.
2016-02-29 19:10:42.029 qlmanage[3873:130464] void __CFPasteboardSetup() : Failed to allocate communication port for com.apple.CFPasteboardClient; this is likely due to sandbox restrictions

I found a similar question that had a number of debugging techniques in it.

Performing my same command line preview with a high debug setting qlmanage -d 4 -p anyimagefile.jpg | grep public.image resulted in seeing extensions registered.

[DEBUG] Registering <QLGenerator Image.qlgenerator> for public.image
[DEBUG] Registering <QLGenerator /Applications/Dropbox.app/Contents/Library/QuickLook/DropboxQL.qlgenerator> for public.image

So, I blatantly renamed the DropboxQL.qlgenerator, which curiously had a very recent modification time on it, and suddenly the preview-using-space problem went away.

Finder still does not display icon previews for these types.


Now it does.

  • I'm really hesitant to point the finger at a Dropbox update; those folks really have their act together. But it's really odd that taking their QuickLook extension out of the equation solved the problem. Commented Mar 1, 2016 at 0:38
  • I am having the same problem. Fingers should definitely be pointed to Dropbox. Have you already complained to them?
    – Szabolcs
    Commented Mar 1, 2016 at 8:44
  • @user1155120 The DMG only has an installer that will download the actual Dropbox app (that in turn contains the QuickLook generator).
    – Szabolcs
    Commented Mar 1, 2016 at 8:44
  • I made a forum post: dropboxforum.com/hc/en-us/community/posts/…
    – Szabolcs
    Commented Mar 1, 2016 at 8:52
  • 1
    – user90735
    Commented Mar 1, 2016 at 9:00

1 Answer 1


It appears this is a Dropbox issue. While I had raised a question on Twitter, thanks to @szabolcs for creating a forum post, where others have chimed into.

Remove the /Applications/Dropbox.app/Contents/Library/QuickLook/DropboxQL.qlgenerator file.

@user1155120 was spot on; the beta version should be unchecked on the dropbox.com site, to prevent getting unstable updates. Download a new copy (v3.14.7 as of the time of this writing in 2016-03-02) and reinstall.

  • I can't believe it's been two years and Dropbox haven't fixed this. I'm on High Sierra and quicklook doesn't work as long as dropboxQL.qlgenerator file is installed. Commented May 8, 2018 at 1:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .