1

I have a MacBook Air A1237. I can hear the "dong" from startup, but in OS I couldn't hear anything.

In System Preferences, as output, I see only headphones. If I plug in a headphone I can hear sounds, music. If I plug out this, nothing happend. The internal speakers are not showed. I've tried to reset NVRAM and SMC, install a new copy of OS, same problems. I tried to clean with a toothpick, nothing happened. Any other idea to solve the problem?

1 Answer 1

1

Generally, this issue indicates a stuck pin in the headphone jack and/or a hardware issue with the sound driver.

For the headphone jack, take your headphones and RAPIDLY plug/unplug them about 10 times in your Macbook. This should be enough to reset the pin and get it working again. Also, check for any debris that could be inside - a nasty lint bunny may be hiding inside causing some wreckage (heck, I've even seen wood inside of them). I know you said you cleaned the jack with a toothpick, but do this as well since a toothpick may not always reset the pin.

Should that not correct the issue, it may be an issue deeper with the computer. Since you already went through and reinstalled the OS, I'd say your next step would either be running Apple Diagnostic or Applecare service done on the laptop.

2
  • Thank you. I've cleaned already. i plugeed in and out...... more that 100 times :) no result. Maybe if i could find a spare part (jack+usb) to check....
    – Vilau
    Feb 29, 2016 at 20:10
  • @Vilau do you see a red light coming out of the headphone jack when the headphones are not plugged in?
    – smoooosher
    Feb 29, 2016 at 20:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .