I have tried to use the following method to install Windows 10 on my early 2008 Mac. Running OS X 10.7.5. Intel Core 2 Duo. 4 GB.

How do I get Windows 10 installed on my macbook pro (late 2008)

Following the instructions using 64bit version of the Windows 10 iso and having bless the partition etc, when the time comes to restart the machine to install Windows 10 from the boot DVD containing the .iso file I get the two DVD option (Windows and EFI). On selected Windows it goes to a black screen with a blinking cursor in the top left corner. It freezes on this and nothing happens.

marks-macbook:~ markcollacott$ diskutil list
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:      GUID_partition_scheme                        *2.0 TB     disk0
1:                        EFI                         209.7 MB   disk0s1
2:                  Apple_HFS Mark's Macbook          1.2 TB     disk0s2
3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
4:       Microsoft Basic Data WINDOWS                 753.6 GB   disk0s4
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:                            J_CCSA_X64FRE_EN-US... *4.0 GB     disk1
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:     FDisk_partition_scheme                        *8.0 GB     disk2
1:                 DOS_FAT_32 NO NAME                 8.0 GB     disk2s1

marks-macbook:~ markcollacott$ sudo fdisk /dev/disk0
Disk: /dev/disk0    geometry: -1539437/4/63 [-387938128 sectors]
Signature: 0xAA55
        Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [      start -        size]
 1: EE 1023 254  63 - 1023 254  63 [          1 -      409639] <Unknown ID>
 2: AF 1023 254  63 - 1023 254  63 [     409640 - -1861551096] HFS+        
 3: AB 1023 254  63 - 1023 254  63 [-1861141456 -     1269544] Darwin Boot 
*4: 0B 1023 254  63 - 1023 254  63 [-1859870720 -  1471932416] Win95 FAT-32

marks-macbook:~ markcollacott$ sudo gpt -r show /dev/disk0
gpt show: /dev/disk0: Suspicious MBR at sector 0
       start        size  index  contents
           0           1         MBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6         
          40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      409640  2433416200      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  2433825840     1269544      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  2435095384        1192         
  2435096576  1471932416      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
  3907028992         143         
  3907029135          32         Sec GPT table
  3907029167           1         Sec GPT header

Is there something I can change or how might I get around this roadblock?

I have not used any Windows version prior. Screen size is 13".


3 Answers 3


Brother I'll give you some sincere advice- Any mac under 4gb ram and older than the 2012 model should stay away as far as possible from Windows 10. I have installed Windows 10 in more than 4 ways and have been devastated in every scenario cause my mac was slower than a snail every time. I have exactly the same mac as you. But if you insist, here's what I've done:

  1. Back up your Mac.
  2. Download tuxera 2015 (specific version)
  3. Open Disk Utility
  4. Create partition and name it Windows, formatted as tuxera ntfs (if this works forget step 1, if it doesn't you'll have to reinstall macOS on your mac again and start from step 2)
  5. Download Windows 10 .iso and mount it
  6. Copy all folders to the windows partition and label them red color
  7. After that you can install refit mac
  8. Open refit and copy EFI onto the Macintosh HD
  9. Open terminal and drag and drop refit folder in the terminal window and press enter. Write password and press enter.
  10. After that write another a code in terminal as follows: ./enable.sh
  11. Now you just restart and choose windows from refit boot menu

That's it, just go through the installation.

After that you have to install some app called drivethelife or something (i dont remember look it up) and install the drivers.

Restart in macOS and delete the color labeled folders from windows and if you want to delete refit just delete the EFI folder from Macintosh HD.


I assume you are trying to install a 64 bit version of Windows 10 because your processor is 64 bit. After Reviewing the web site Install Windows 7 and earlier on your Mac using Boot Camp, I found Apple documents only 32 bit versions of Windows 7, Vista or XP are designed to run on your Mac Book (2008).

The computer used to enter this answer is a 20" mid 2007 iMac running 64 bit Windows 10 Pro. The same web site documents that my iMac can not run 64 bit versions of Windows, so this site can be wrong. On the other hand, just because I can do it does not mean you will be able.

The first thing I would check is the Mac's firmware. Current Apple firmware can be found at this site: About EFI and SMC firmware updates for Intel-based Mac computers.

Neither of our Macs can boot the Windows 10 installer from a USB flash drive. So, there is no point to trying that method to install Windows 10.

My iMac can not boot from a standard 64 bit Windows installation DVD. This is because these DVDs contain both the BIOS/MBR and EFI/GPT methods of booting. When you tried your DVD, the icon labeled "Windows" was the BIOS/MBR method and the icon labeled "EFI" was the EFI/GPT method. If you are having the same problem as me, you would have to remove the EFI/GPT method from the DVD. Unfortunately, this requires a machine running Windows. The procedure is given at “Select CD-ROM Boot Type:” error during Windows install.

The XP, Vista and Windows 7 32 bit DVDs only contain the BIOS/MBR method of booting. I assume this is also true for Windows 8, 8.1 and 10. If you can find a 32 DVD, you could test to see if dual booting is your problem. You can download a free 90 day trial of 32 bit Windows 10 Enterprise at this site.

Another option will be to install VirtualBox on you Mac. Since you are using OS X 10.7, you would need to download and install the last version 4.3 release of VirtualBox. This would allow you to test the DVD by booting from the DVD in a Virtual environment. You could also install Window 10 in the virtual environment, but I am afraid your Mac is to slow for this to be of any use. (If you do, be careful not to active the Windows 10. To be safe, maybe you should not be connected to the internet while using the virtual machine.)

You could use VirtualBox to just install Windows to Mac's Boot Camp partition and then run a physical version of Windows 10 without the aid of VirtualBox. The difference between this method, and directly using the DVD, would be that you could remove the EFI files before booting the Windows 10 installer. The procedure would be a merger of the instructions given here and here.

I am sure I have not answered all you questions. Feel free to post comments with additional questions.

BTW, the partition tables you added to your question look good. The output from the command gpt shows the GUID Partition Table (GPT) used by OS X. The command fdisk shows the legacy Master Boot Record (MBR) partition table that will be used by Windows. The first entry in both tables is the (hidden) EFI partition. This partition always starts at different values in the tables, but ends at the same value. The next three are your OS X, (hidden) OS X Recovery and Boot Camp partitions. The negative values appear to be a bug in fdisk. The values are suppose to be printed as unsigned values. What is shown are signed values. You can convert to the correct values by adding 2 to the 32nd power (i.e. 4294967296). In other words:

fdisk value                gpt value 
-1861551096 + 4294967296 = 2433416200
-1861141456 + 4294967296 = 2433825840
-1859870720 + 4294967296 = 2435096576
  • Thanks David. I am going to attempt your method removing the EFI boot from the disk image tomorrow. Failing that I will try the 32 bit version. Commented Feb 28, 2016 at 11:51
  • Unfortunately both methods failed. I was able to remove the EFI boot option using the steps shown in the link above. This removed the EFI boot option, however on selecting the Windows option I still had the black screen with the blinking cursor. I also tried installing the Windows 10 32 bit option. On first attempt it didn't show a dvd Boot option. Commented Mar 1, 2016 at 15:05
  • I restarted the MacBook again and this time it did show the dvd option. On choosing this I was presented with a black screen with "press any key to boot from cd or dvd....." On pressing any key nothing happened. I am thinking maybe my devices (keyboard, optical drive) is not being recognised during the boot procedure? Commented Mar 1, 2016 at 15:07
  • 1
    @Mark: The only options left would be to try booting without using the DVD. One method involves putting the contents of the DVD or iso into the internal drive partition and then boot from that partition. The other method involves installing Windows in the partition but first running Windows using virtual hardware. It this work, you then switch to the physical hardware. Both been used to successfully install Windows 7/8/8.1 on other Macs. Both methods use VirtualBox which is free and does not take much space to install. A third option would be to install Windows 7 first and upgrade to 10. Commented Mar 1, 2016 at 16:17

It is indeed the boot EFI pointing problem. Simple fix by pointing boot sequence in the Startup disk; Windows 10 installer will boot up from there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .