1

I have an iMac (running OS X 10.11.3) with a dual disk setup. A ssd for the OS (with Filevault turned on) and a HDD for storage that is formatted OS X Extended and Encrypted.

The intention is to symlink some user directories onto the storage HD.

The problem that I have is when I try to delete files on the storage HD I am prompted for a password (the user password as opposed to the password for the encryption). Also when I move files on the storage HD they are essentially copied as opposed to moved.

I have tried:

sudo chown -Rv username directory

but that hasn't worked.

I have also tried changing the Sharing and Permissions privilege settings to Read & Write for all folders and files but that hasn't worked either.

Anybody with any advice would be greatly appreciated, thanks.

1 Answer 1

1

OK, I found a solution. If anybody would like to correct my approach please let me know.

With the storage drive (get info) -> 
Sharing & Permisions -> 
Checked 'Ignore ownership on this volume'

The next step might have been made redundant by the previous step, but I also did the following:

Directory on storage drive with user directories -> 
Sharing & Permission -> 
My User Profile, Read & Write

This appears to have done the job, can delete and move items as expected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .