2

I am trying to generate an app specific password, as I can not get Thunderbird on Ubuntu, to connect to the icloud server. I found a few posts on the web that infer, you now have to generate an app specific password, using the manage your apple id site. the instructions at the apple site say to log into your account and click on the edit button in the security section, and then to click on "generate password". When I do this, no option appears to "generate password"

Steps outlined by Apple:

Sign in to your Apple ID account page.
In the Security section, click Edit.
Click Generate Password and follow the steps on your screen.
  • I was able to log in using Safari just now. The element is a javascript button - so you might need to try another browser or be sure you aren't blocking javascript for that site. Would it be helpful if I uploaded an image of what you should see and a code snippet? <button class="btn btn-link btn-appPassword">Generate Password...</button> – bmike Feb 23 '16 at 17:59
  • Thanks for checking. I tried in Ubuntu Chromium and Firefox and then Chrome in Windows 10, but the button is still not there. – uberdave Feb 23 '16 at 19:07
1

It appears that app specific passwords are not needed to access icloud on Ubuntu, using Thunderbird. I refired up an old box, I had stashed away; and, it connected to icloud fine, on Ubuntu using Thunderbird. I set up this account nearly 2 years ago and it works, with no app specific password. However, I never was able to set an app specific password at the apple site. So, I am closing this as, I don't actually need one.

0

That's a bummer - many of Apple's iCloud web apps work well across PC and UNIX browsers - but you might need to reach out to Apple support to get a list of supported browsers or at least alert them to a bug in their code.

I would double check that you have two-step verification enabled for the Apple ID in question and then try either Safari or Mobile Safari to browse to the site. Non two-step accounts can't create app-specific passwords in the current design of the service.

I've verified that both Safari on OS X and iOS 9 work fine with the generate password link. If you need support, they are at http://www.apple.com/support/appleid/ or the contact us link from your AppleID page.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .