1

So here's the thing. My iMessage on the MBP is simply not working, when I use my MBP the way I want to. What way is that? Since it has no Ethernet connector, I bought a USB 3 to Ethernet box, that does its job nicely. iMessage does work with it. I have no WiFi in my office, so to keep costly traffic away from my iPhone I setup the MVP to share its internet connection via WiFi. From this moment on, iMessage will no longer work. And I know why, but I don't know how to fix it. Reason for the why is that iMessage (as opposed to every single other application on my MBP) explicitly takes en0 as the networking device to send and receive data. But en0 is the local WiFi, my Ethernet device is en3. The local WiFi is just a bridge for my iPhone, not "the internet". But iMessage is to dumb to get that. It is smart enough to know not to use en0 when WiFi is turned off or not connected though, and then will use en3 readily. So the question is:

How can I convince iMessage to always use en3?

2

Open System Preferences > Network, click the tiny gear at the bottom of your services panel next to the + and - buttons, and select "Set Service Order". Drag your ethernet service (en3) to the top (or at least above en0/Wi-Fi) to send all outgoing network traffic through en3.

Service Order

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .