I'm currently doing a lot of chemistry writing in Google Docs. Google Docs is great for it because Cmd+. formats as superscript and Cmd+, formats as subscript... both of which supersaturate chemical writings (fear not, that's my only pun). Superscript works great, but Safari has an overriding Cmd+, which brings up Preferences-General and highlights Homepage, so subscript doesn't work. I haven't yet found a way to disable Safari's particular shortcuts, so I'm hoping someone here does.

  • 1
    Have you tried doing it another web browser, like chrome/Firefox/third party browser? – user2277872 Feb 23 '16 at 2:34
  • 1
    3rd party apps are the answer, here's some idea: lifehacker.com/5882684/the-best-keyboard-remapper-for-mac-os-x here's one that has an answer specifically per application apple.stackexchange.com/questions/148845/… – JimLohse Feb 23 '16 at 3:20
  • I'd prefer to find the real solution rather than a workaround. I use Safari the majority of them time because it's more power efficient and, honestly, on the Mac it looks best. Chrome's mac application is a bit shoddy. – Sllew Feb 24 '16 at 3:58
  • Chrome works! You can type your subscripts without issue! – Steven Tang Nov 3 at 2:35

looks like this answer related to a similar problem might do the trick: https://stackoverflow.com/a/20692071/620141

in short:

  1. Edit ~/Library/Preferences/com.apple.symbolichotkeys.plist (you can use Xcode).
  2. Find the code for kCGHotKeyLookUpWordInDictionary (70), and set 'enabled' to OFF (if it's not there just create an entry '70' with 'enabled' = OFF).
  3. Restart your system

EDIT: In your case, it should be:

Key Down
    Characters: ,
    Unicode:        44 / 0x2c
    Keys:       ⌘,
    Key Code:   43 / 0x2b
    Modifiers:  1048848 / 0x100110

so you should be using key code 43 with modifier 1048848

Extra help:

  • This looks promising, but the tools to find the key codes are failing me. Either that or I'm having trouble understanding them. Could you help me find the code for Command + , and then, if it works, I'll mark your response as answer. – Sllew Feb 24 '16 at 3:57
  • @Silew sorry I couldn't get back to you earlier. I've updated the answer, you should (untested) be using key code 43 with modifier 1048848 Lemme know how it went – Jonas D. Mar 4 '16 at 12:37
  • I'm sorry, I must be doing something wrong. There was no 43 key, so I made one. I added an item 'enabled' to 43 and set it as NO. (every time I made a change I restarted to see if it would be fixed) So then I followed the format of the other keys and created a value dictionary. To 'value' I added 'type' and set it as 'standard,' then added 'parameters' as 'item 0 = 1048848' and 'item 1 = 44'. It's still not working. Do you know from that description what I'm doing wrong? – Sllew Mar 5 '16 at 21:33

System Preferences > Keyboard > Shortcuts > App shortcuts > +

Title it "Preferences..." and remap it to CommandAlt+, and voila, you can now use Command, in Google Docs.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .