3

Whenever I try to add a clock to the World Clock widget in the Today area of Notification Center, it never gets added. Sometimes I can’t even search for the city I want to add. However, whenever I am able to search for a city, it finds it, and when I press enter or click on the name, it behaves as it should be, but the clock never gets displayed.

enter image description here

And yet it remains like this:

enter image description here

What I tried so far:

  • restart Finder;
  • restart computer;
  • delete the widget and add it back.
  • Have you tried to restart the system? – Mattia Feb 22 '16 at 22:27
  • @Mattia, yes, I did and nothing changed. – Alex Feb 23 '16 at 7:08
  • Try deleting the widget and adding it again – user2277872 Feb 23 '16 at 7:16
  • @user2277872, done that as well — no luck. – Alex Feb 23 '16 at 7:36
5

The solution is you need to click the (i) ("Info") button in the upper right of the widget before you click on the "Add" button.

If not an explicit bug, this is certainly a major usability issue, but only is an issue when adding the first clock (otherwise the "Add" button doesn't show up until you press Info). I had run into this as well and couldn't figure it out for months. Finally poked around at it more just now and finally figured it out.

0

I just tried this. Did you click the name of the city that came up? If so, it should add without issue. If that doesn't work, relaunch Finder and try again.

  • Already tried. I also tried restarting the whole system. – Alex Feb 23 '16 at 7:09

You must log in to answer this question.

protected by Community Apr 28 '16 at 13:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .