2

One of our Mac Pros at work is having issues shutting down. On shut down, the screen will turn black and a small gray loading wheel will come up in the center of the screen. It will stay like this no matter how long you let it sit until you physically press and hold the power button. We've already let it sit like this over the weekend so I know it's not just a waiting game.

I've tried just about everything I can think of including resetting the PRAM and SMC. Tried force quitting all apps before attempting to shut down..

These issues started randomly one day while the computer was still running Yosemite so I figured it has something to do with the OS. Did a fresh install to El Capitan and the same thing keeps happening on shut down.

Now I'm thinking it's something hardware related.. Does anyone have any experience with an issue like this?

The Mac Pro is a 2008 2.8GHZ 8 core 3,1

EDIT Booted into verbose mode and this is what we got:

Booted into verbose mode and we have the following:

Failed to send exception EXC_CORPSE_NOTIFY. error code: 5 for pid 436

Failed to send exception EXC_CORPSE_NOTIFY. error code: 5 for pid 455

continuing

process_svrmsg_items: disabling svrmsg notify, error: 60

EDIT #2

The PIDs change every time we shut the computer down so it doesn't seem like there is just one program causing this issue. We did some tests with swapping out ram, taking ram out, and nothing has made a difference so far.

Today on shut down, we got a couple more random and different PIDs but got this for the first time..

smb2fs_smb_change_notify: smb2_smb_change_notify failed 57

This just kept continuing to pop up until we manually shut the computer down..

  • Not that it significantly affects the question, but a 3,1 is an Early 08. I'd run a hardware test, or remove all drives except boot drive, all RAM except one, test again. I once had this on a 3,1 but I actually can't now remember what it turned out to be. – Tetsujin Feb 22 '16 at 13:30
  • Oh yeah, it is an early 2008.. not sure why I was thinking 2006.. I'll give that a shot and see what happens. – drlexus Feb 22 '16 at 13:53
  • In addition to Tetsujin's suggestions, you should reset the SMC and reset NVRAM. You should also startup in Safe Mode to clear out any caches and run a disk check. – IconDaemon Feb 22 '16 at 14:57
1

Have you tried booting it in verbose mode? i.e. when the startup sound is playing, hold down Command-V so that it scrolls a text-mode view during startup and shutdown. During shutdown, it'll probably get stuck on what you're looking for and then you may have a better idea of what is causing troubles...

  • Thanks, @bjb edited my original post with what we found in verbose mode – drlexus Feb 24 '16 at 13:32
  • @drlexus can you find out what those PIDs are? You could ps -Af (i.e. get a list of all processes with PIDs) in the terminal and saving to a file before shutting down and then reference later? – bjb Feb 24 '16 at 17:54
  • Thanks @bjb updated the original post again. Thanks for the help so far. – drlexus Feb 26 '16 at 22:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .