Usually, when I connect to a server (cmd "⌘" + K), I can see the list of my favorite servers :

Connect to Server with favorites

But after upgrading to El Capitan (Mac OS 10.11.X) and after freshly booting my MacBook, this list sometimes disappears and I can't add a new server to it ("+" button doesn't works) :

Connect to Server without favorites

Does anyone have a similar problem and knows how to resolve it?

  • I can't replicate the problem. I just (within the past 48 hours) upgraded a 2009 MBP and 2012 iMac to 10.11 and both are working fine here. Is this a clean install, an in-place upgrade or a migration from an older version of OS X?
    – Allan
    Commented Feb 21, 2016 at 1:22
  • I'm upgrading my 2011 MacBook Pro (was on Snow Leopard) to newer's Mac OS version each time from the beginning and I have never encountered serious problems. May be it's problem of Finder's cache linked to my other unsolved problem : apple.stackexchange.com/questions/227112/…
    – Klemart3D
    Commented Feb 22, 2016 at 7:49

2 Answers 2


I had this problem too. Here's how I fixed it: delete the folder ~Library/Application Support/com.apple.sharedfilelist/ and then use Activity Monitor to kill the sharedfilelistd process belonging to your user. Then I relaunched Finder for good measure. Works now!


I had this problem on my iMac running 10.11.6. I opened Activity Monitor and killed all sharedfilelistd processes. (There were two. One under my account and one under root) I then killed the Finder, also using Activity Monitor, and relaunched it by clicking on it in the Dock.

All of my saved favorites then appeared when I opened the Connect to Server dialog.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .