0

When trying to open new folder on Desktop from Finder-menu Terminal opens instead. Also I cannot move documents and folders onto Desktop- get a "forbidden" sign (= white circle with slash through it). When accessing the computer as other user Finder works fine. Was running Mac OS 10.7.5 and it did not help to upgrade to El Capitan which I downloaded a few days ago. After repairing permissions the report stated

Warning: SUID file “System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent” has been modified and will not be repaired.

Disk Utility says the disk is OK.

I have tried to remove my user-systempreference-plists for Desktop and Finder, but everything got worse (spotlight could not find the right files, etc.) so I put back the plists.

Is this a sign of a "damaged directory"? Can it be fixed by Disk Warrior? Please help!

1

Found a solution to the problem here:

Enter the following command in the Terminal window in the same way as before (no typing):

xattr -c ~/Desktop

Try the action again. If the same thing happens, relaunch the Finder by selecting Apple menu > Force Quit... > Finder and pressing return or clicking Relaunch.

0

I would first swap out your keyboard/mouse and see if the same behavior occurs. I've had issues like this where keys are stuck and are causing unintentional commands. From your issue description, unintentional commands are happening when you attempt basic commands ( open causes a terminal window, copy is causing an incorrect operation).

The extra key will cause the command the operating system is intending to be something completely different. If you're just using an internal Macbook keyboard, you can disable the trackpad when a new mouse is plugged in using the System Preferences mouse control.

If that doesn't work, then I would resolve them as two separate issues: terminal windows are opening and you don't have access to your desktop.

Regarding permissions, first check through the GUI what it is listing.

/Users/<yourname>/Desktop

and click on the Desktop folder and press Command+i to get info. From the info you should be able to see what permissions are listed. If you aren't set to read+write then change to read and write and test.

Regarding your terminal window opening up, check your system preferences for the keyboard shortcuts and see if open finder in new terminal window is set. If it is unset it and test if that allows you to copy files correctly.

  • Found solution to the problem at discussions.apple.com/message/17853202#17853202. Copied text from that page and dragged it into my Terminal window, then force-quit Finder and relaunched it. Now everything works fine! Took your advice and checked the Keyboard shortcuts. They look OK. Great that people like you all are ready to help! – Marianne Amaloo Feb 21 '16 at 0:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .