1

Macbook with OS X 10.11.3. No iCloud account, regularly updated via softwareupdate -i -r && brew update && brew cask update. Rather restrictive firewall(ing) via LittleSnitch and pf. Case-sensitive partition.

Two user accounts, let's say ROOT and USER. First is used for exceptional cases like installing new software and the second one is for day-to-day tasks, web browsing, etc.

Since very recently, password for USER is being set to unknown value after each reboot. I am able to login as ROOT and do sudo passwd USER, but I'm concerned this could be a consequence of malware or so.

Parts of various log files I've found a tad suspicious:

accountpolicy.log:

Feb 18 22:10:45 (75.25.1) PasswordChangeAllowed completed: record "USER", result: Success (0).

system.log

Feb 18 22:10:33 USER com.apple.preferences.users.remoteservice[481]: ### ODFDEResetPassword failed
Feb 18 23:36:33 USER com.apple.preferences.appstore.remoteservice[2230]: Failed to connect (_asnPasswordSettingsManager) outlet from (AppStorePref) to (ASNPasswordSettingsManager): missing setter or instance variable


Before reinstalling the system, is there any recommended recipe I should try?

  • Actually, I'd just reinstall OS X, and if that fails, start as new (reformat HD) and manually copy over applications & files from your backup. I've had a problem with logging in too, and that seems like the easiest way to fix it. – At0mic Feb 20 '16 at 21:58
  • @IronCraftMan, Thanks, I'd like to find out what actually happened and how to avoid it in the future. – asv Feb 21 '16 at 3:51
  • Can you login to the USER and use the OSX built in tools for reseting the password via the System Preferences? My guess is just changing the password at the CLI might not be updating the entire system OSX uses. – Todd Dabney Feb 21 '16 at 6:24
  • Also do you have a reason for the case-sensetive partition? It's my understanding this can cause a whole host of it's own problems. – Todd Dabney Feb 21 '16 at 6:25
  • @ToddDabney, tried it, same result. Just used to case-sensitive FS. Any specific reason why not to use it in OSX? – asv Feb 21 '16 at 10:40

You must log in to answer this question.

Browse other questions tagged .