I've got a problem in that some app icons on my Apple Watch seem to be missing their artwork. This only happens to a few apps at a time, seemingly randomly and I haven't noticed a specific trigger. The apps otherwise work normally and the icons are present if I look at the list of apple watch apps on my iPhone.

If I uninstall and reinstall the app, that usually fixes it temporarily at least but I was wondering if there was a quicker/easier way to fix it or prevent it from happening in the first place.


  • I have the same issue, any solutions?
    – user173513
    Commented Feb 29, 2016 at 23:07
  • Restarting my watch fixes many ills, have you tried that? Hold both the side button and the crown down
    – cmason
    Commented Apr 24, 2020 at 13:05

4 Answers 4



I hope this help!................................

  • 2
    Welcome to Ask Different! We tend to refrain from link only answers, as they decrease legibility and are susceptible to link rot. Could you please add any relevant info from your link to the body of your answer?
    – JMY1000
    Commented Feb 8, 2018 at 6:56

The only way I found to fix, is to use the Apple Watch Application on your iPhone. Remove the application (slider off "Show App on Apple Watch"), once it's uninstalled, reinstall it (slider a=back on "Show App on Apple Watch"). Not a great solution, especially when you have 8 or more apps missing their artwork, like I did; However it works.

  • Didn't seem to work for me. Commented Apr 4, 2017 at 15:14

I would unpair the Apple Watch, reset the watch and then then pair it again and make sure that you are on the latest update for your watch.


I figured out that I had not set the target of the corresponding folder to the correct one. I for example have three separate folders, Main, Watch and Watch Extension. I had not set the target for the Watch folder and the app icon therefore did not load, now it works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .