I normally get new podcasts by doing the following on my iPhone:

  1. Go to my list of podcasts
  2. Select the podcast I'm interested in getting an episode for (e.g this week in google TWiG)
  3. Select 'Get More Episodes' This takes me to iTunes where I can normally see a list of all the episodes and download the ones I want. However, all I see now is the podcast logo (e.g., This Week in Google), how many reviews the podcast has had, but no list of podcasts.

I've tried deleting a podcast (by deleting all the episodes on my iPhone) and then trying to add it again via iTunes, but still no list of podcasts.

Where has the list of podcasts gone? How do I get them back?

2 Answers 2


I'm having the same issue with TWiT and This Week In Tech. When I try Tekzilla, I can download in some formats (HD M4a) but other formats (QT small or QT Large) just show the logo with no episodes to download. Sounds like Server side issues.

  • Yes, I get the same the problem with TWiT too. Thanks for letting me know it's not just me.
    – TonyBooker
    Aug 23, 2011 at 9:59
  • I saw on apple's forum that it is a backend problem and they said 48 hours to fix.
    – Skippard
    Aug 23, 2011 at 10:12
  • Brilliant. Thanks! Do you have a link?
    – TonyBooker
    Aug 23, 2011 at 16:23
  • still not working yet. Grrrrrrrr
    – Skippard
    Aug 23, 2011 at 23:29

Which version of iOS are you running? I've just checked and it's fine for me so it's not a server side problem. The obvious recommendations are try rebooting etc. If you go into iTunes can you access any podcasts from navigating through rather than from the iPod app?

  • I've tried rebooting my iPhone, but it makes no difference. The strange thing is I can see lists for some podcasts, but not for most of them. I don't have iTunes on my PC, but have had no problems downloading from iPhone before.
    – TonyBooker
    Aug 22, 2011 at 11:28
  • Sorry I wasn't clear on that last bit, I meant iTunes on your device. I had a similar issue (I'd press Get More... and it'd just take me into the iTunes store), and I had to end up going through iTunes, into the Podcast section and going from there. Aug 22, 2011 at 11:30
  • Sorry misunderstood. If I try with iTunes on my iPhone it shows the same thing as going to it via the podcasts list on my device - i.e., no podcasts to download. Very odd.
    – TonyBooker
    Aug 22, 2011 at 11:34
  • Sounds like a communication issue, is it over 3G or wifi or both? Aug 22, 2011 at 11:38
  • I'm getting the problem over WiFi. Can't get 3G at the moment.
    – TonyBooker
    Aug 22, 2011 at 11:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .