5

I'm trying to update my version of Keynote to 6.6.1 (it's now 6.2.2) so I can open presentations created in newer versions, but every time I click the "update" button on the App Store, all I get is the spinning wheel thing in the top left corner, which says "checking for updates" by it. Nothing downloads, nothing happens. Any suggestions?

I've just updated to El Capitan 10.11.3

  • What version is it now? – Tetsujin Feb 17 '16 at 13:01
  • 1
    It's now 6.2.2 (updated original message to reflect this). – dmt Feb 17 '16 at 13:32
1

Most likely this is down to the fact that your OS is not updated. The current version of Keynote requires macOS 10.12. You can confirm this by deleting Keynote from your applications folder, starting AppStore and installing Keynote. You will get an error message that a later version of your operating system is required.

0

Search for "Keynote" in the Mac App Store, and where it usually says "Download," it should say "Update." See if it will update that way. If not, then your best bet is to delete Keynote and re-download it.

0

Now solved

After restarting, the new version of Keynote was there and ready to use. I have seen similar problems on other fora - it seems like it gets downloaded, but this doesn't show anywhere and the new version is not activated. If you try to delete Keynote, you get an error message saying other processes are still using it.

Restarting does the trick.

  • 2
    Nope. Still not updated (trying to update to 7.0.5). App Store still has "Update" button which still spins indefinitely. Still have version 6.6.2. I am going to guess that I need to update the whole OS to Sierra (sigh). – wcochran Nov 5 '16 at 17:04
-1

Sometimes your Mac may accidentally redownload Keynote without deleting the old one. Check in Applications and make sure you don't have two versions of Keynote hiding.

You must log in to answer this question.

protected by Community Feb 21 '17 at 18:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .