Mac OS X Lion introduced a new feature where in many applications you can press (Command-Control-D) to produce a popup with the definition for the word under the mouse cursor. A side effect of this is that you can no longer use the same shortcut to access functionality in other applications (for example, Emacs).

Is it possible to either

a) disable the word definition Command-Control-D keyboard shortcut, or
b) change the word definition keyboard shortcut to something other than Command-Control-D?

To disable the Control-Command-D binding enter the following in the terminal:

defaults write com.apple.symbolichotkeys AppleSymbolicHotKeys -dict-add 70 '<dict><key>enabled</key><false/></dict>'

and restart.

  • This is the most reliable way to disable the command, was difficult to find this! – Joel Feb 14 '14 at 23:19
  • 1
    Restarting is a key part. I've seen the defaults invocation mentioned in a few places on the web, but none of them mentioned restarting, which is required for the new setting to take effect. (At least on OS X 10.10.1.) – Davor Cubranic Jan 16 '15 at 18:37
  • 1
    Without disabling this key, `C-M-d' did not work on Emacs GUI when using Command as Meta (see here). I've sent a PR to mathiasbynens's .osx dotfiles so that it gets disabled there and many Emacs users can benefit. Vote it up! :) – Galder Zamarreño Feb 24 '16 at 8:14
  • Looks like PR was closed, but at least issue is well documented. – dev Mar 17 '17 at 15:43
  • this is the only way to free this key combination (for use in another app) many thx bro!! – Alexandre Reis Ribeiro Jan 24 at 11:40

Yes, through System Preferences, you can change and disable keyboard shortcuts. Go to System Prefs -> Keyboard -> and hit the tab Keyboard Shortcuts. Click the Services entry, and scroll down to the Searching set of shortcuts. Uncheck the lookup in dictionary to disable it, or double click the space to the right to change the shortcut.

  • 4
    There is no keyboard shortcut entry for this particular key combination in System Preferences. – Zane Shelby Sep 6 '11 at 23:34
  • 1
    Gaah! This is just now starting to bite me. Also: Hi, Zane! – offby1 Feb 14 '13 at 3:05

In Lion specifically, System Preferences / Keyboard / Keyboard Shortcuts / Searching / Look Up in Dictionary will allow you to assign an additional shortcut keystroke to do a Dictionary lookup, but it won't disable Command-Control-D for other applications to use.

In Snow Leopard, the same Command-Control-D lookup is available, but it can be reassigned by the user.

I hope this is just seen as a bug to correct in an update rather than a new 'feature'. I'd grown accustomed to mapping that combination to other things in SL.

  • 1
    in macOs Sierra 10.12.5 , its under  --> System Preferences --> Keyboard > Shortcuts (tab) > Services ( on left pan) > Searching ( on right pan) and then Uncheck "Lookup in Directory" checkbox – pro.mean Aug 4 '17 at 18:04

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.