enter image description here

Like when I go to one of these pages iTunes automatically opens up. It's really annoying. How can I disable this?

2 Answers 2



It looks like the browser you are using is chrome, so follow these steps

  1. Go to chrome://settings/contentExceptions#javascript
  2. add itunes.apple.com and mark "Block"

enter image description here

If you want to see the app without seeing the "Opening the iTunes Store." page, visit The iTunes Link Maker and see if you can find the app on there.

(that was my solution before, but it seems now iTunes preview shows the app with a "Opening the iTunes Store." banner. By disabling Javascript on that page, you won't see the banner)

  • Let me know if I got the browser wrong, and I'll edit the answer. The link that I provided has the solutions for Firefox and Safari too. If they don't work, research on disabling Javascript for certain websites / iTunes
    – MrU
    Commented Feb 17, 2016 at 9:48
  • This doesn't seem to be working for me with the Apple Music app.
    – Splaktar
    Commented Dec 23, 2020 at 2:33
  • New link: chrome://settings/content/javascript
    – Skywise
    Commented Aug 2, 2023 at 8:23

This does not happen for me on El Capitan. When I search for an app, Evernote for example, the first Google result is the app listing on iTunes. (Screenshot below.) If I want to download the app, I have to click the blue View in iTunes button below the app icon. iTunes is never opened until View in iTunes is clicked. What version of OS X are you running? enter image description here

  • Unfortunately this happens for me on macOS Sierra.
    – Oion Akif
    Commented Jan 28, 2017 at 18:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .