1

I have a podcast that works in iTunes, but when I submit it to the iTunes store via podcastsconnect.apple.com, I receive "Validation failed" together with "Can't read your feed". It works when I open it directly in iTunes, and it appears to be a valid feed. Is there anything else I could try?

5
  • Pretty sure this is SSL related. Still debugging - I'll post an answer if ever I figure it out. Feb 18, 2016 at 22:46
  • AFAIK Apple's server side podcast client implementation is Java-based. Again AFAIK Java does not support strong TLS crypto. Test your website with ssllabs.com/ssltest/analyze.html
    – bot47
    Feb 25, 2016 at 18:29
  • Ah - thanks @MaxRied! I suspect the problem is this: Java 6u45: Client does not support DH parameters > 1024 bits. I'll try reducing the number of bits in my DH setup. I also discovered I'm vulnerable to Poodle and get a C - last I checked it was A+, so I must have messed something up. Feb 25, 2016 at 20:15
  • Tell me if this worked, I write an answer then.
    – bot47
    Feb 25, 2016 at 20:50
  • Not yet, sadly. I've switched to a 1024 bit DH key, but still no luck :( Feb 25, 2016 at 22:15

1 Answer 1

1

It turns out the iTunes Store doesn't support certificates from Let's Encrypt, after discussion with Apple Support.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .