0

I think I am having issues trying to connect to servers that are using IPv6. Mainly related to local web development.

On this Github Issue relating to my specific problem and they recommend disabling IPv6 on the Mac and while this does fix the issue I would like to turn on IPv6 if possible, as long as it is secure to do so.

https://github.com/composer/composer/issues/4748

I went digging in the Airport Extreme Router to see if there might be some setting causing an issue. I found this setting that blocks incoming IPv6 connections.

block incoming connections setting

I wanted to see if there was a reason that this blocking of IPv6 incoming was ENABLED and found a security bug from 2007. I am assuming it is fixed?

So the questions are:

  1. Is this setting safe to disable on AirPort Extreme routers?
  2. Would this setting be part of the problem causing me not to connect to IPv6 machines?
-1

It has been my experience, that with OS X, enabling IPv6 is not a good idea. I live in the USA and outside of the USA things may be different. The default should be to prefer IPv6 over IPv4. Since most, if not all, of the USA is still using IPv4, one is better of setting your computer to prefer IPv4 over IPv6. With Windows, this can be done by downloading from this site.

The problem is OS X prefers neither. Instead it tries to determine which is better. The result is you end up waiting. Sometimes this can be a long wait. It is my understanding that if you can configure OS X to prefer IPv4 or IPv6, the operating system will ignore the setting. The only reasonable option is to turn IPv6 off.

  • Thanks for the response. I turned off IPv6 for now, haven't tried set it to prefer IPv6 yet. That might be something to look into trying. I have a mixed setup on the local network so thanks for the links to windows KB. – LLBBL Feb 17 '16 at 13:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .