1

I am trying to configure Wi-Fi on an Apple TV 2 with WPA2 Enterprise.

The Apple TV asks for a profile so I am trying to configure one.

I set up the mandatory "General" settings

enter image description here

the certificate of the RADIUS server

enter image description here

And the Wi-Fi settings

enter image description here

enter image description here

When I install the profile or prepare the Apple TV via Apple Configurator (USB) I just get that the profile is invalid

enter image description here

How can I debug the problem? Is there a way to see a better error description or to validate the profile?

Edit 1

I tried as suggested with a minimal profile

  • The required general infos
  • WiFi with just the SSID (no security...)

I get the same error.

Edit 2

I enabled logging with

defaults write com.apple.configurator LogLevel ALL

after starting the "prepare" I get the error without any log entries. After clicking Stop I just get a single log entry

2016-02-18 15:47:53.177 com.apple.configurator.xpc.AirTrafficService[51010]: ERROR - 0ms - <ACUAirTrafficService: 0x7fca30d03420>: cannot call fetchOperationProgressForOperationID:reply: because: NSError: 0x7fca30d3eb60
Desc   : The operation is no longer available.
US Desc: The operation is no longer available.
Domain : ConfigurationUtilityKit.error
Code   : 0x65 (101)
 (ACUService.m:102)

Edit 3

I tried with "add profile" instead of prepare. In this case I am able to install a profile with the minimal Wi-Fi profile.

As soon as I enable WPA2 Enterprise it fails.

  • Are you using Apple Configurator v2 to prepare and install the certificate? – bmike Feb 17 '16 at 18:26
  • I am using Apple Configurator 2 – Matteo Feb 18 '16 at 6:19
  • What do you mean by "prepare" the certificate? I exported the certificate of our RADIUS server from my Key Chain. – Matteo Feb 18 '16 at 6:20
  • @klanomath how? I just have the possibility to set the time zone settings to automatic or manual. In both cases I cannot connect to the network – Matteo Feb 18 '16 at 15:13
  • @Matteo hmm I suspect that the current (arbitrary) ∂ time (ATV time - Radius server) may be too big (>300 seconds). – klanomath Feb 18 '16 at 15:20
1

Most likely you are trying to apply a setting that isn't supported on the AppleTV 2. I'd start with the typical troubleshooting of start simple and then add more.

So, create the profile with only the General section configured and apply it. If that works, move on to another section. Repeat until it stops working.

Some items to look into are

  • The encryption of the certificate. If it is the wrong size or type, it might not be supported on the ATV2. The device probably can't support the latest encryption methods.
  • Perhaps the PEAP authentication protocol you have selected in the WiFi section isn't supported, so try TLS.

Good luck.

  • A profile with the general section only will not be applied "This profile contains no payloads and cannot be installed on devices" – Matteo Feb 18 '16 at 6:22
  • I tried to create a profile with the certificate only (minimal payload) but it not usable "This profile does not contain a Wi-Fi payload" – Matteo Feb 18 '16 at 7:04
  • Try just the WiFi section but don't add the trust info (so you won't need the certificate). Keep it simple and it doesn't actually have to match what your WiFi network requires (yet). You are just testing if you can delivery any profile at all. – Insomniac Software Feb 18 '16 at 14:41
  • Same error even with a minimal Wi-Fi configuration (see above) – Matteo Feb 18 '16 at 14:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .