I use the English and Korean input sources on my Macbook.

For some reason or other, the English one has a U.S. flag as its icon, but the Korean one has a completely different icon — the letter "⬜" instead of the Korean flag. This really bugs me.

I've tried using the program Ukelele to make my own input source with the Korean flag as its icon, but apparently Ukelele doesn't support the Korean input method.

So is there a way to edit a preexisting input source? I'm looking to change the icon of the default Korean input source on the OS X.

EDIT: Apparently StackExchange thinks all Koreans must be spammers. The letter "⬜" (which has been replaced) looks like this: https://ko.wikipedia.org/wiki/%ED%95%9C

  • Regarding flags, Apple is gradually moving away from them where possible, presumably to "denationalize" keyboards which could be used in various countries. US Extended is now ABC Extended, and there is a plain ABC keyboard for those who prefer not to have the US flag present. Feb 15, 2016 at 4:22
  • I don't seem to have any problem posting 한 here. Feb 15, 2016 at 4:23
  • @TomGewecke Perhaps it's a reputation thing. When I try to type the letter, it tells me to "spam somewhere else." Feb 15, 2016 at 4:28

2 Answers 2


Go to System/Library/Input Methods/KoreanIM.app and view its Package Contents/Contents/Resources. There you will see .pngs for the various Hangul IM's. Try replacing the relevant one of those and see if that does the trick.

  • Where is the file located? find /System/Library/Input Methods/KoreanIM.app -name "*.png" does not show any output. (on macOS 10.15)
    – Blaszard
    May 7, 2020 at 0:52
  • @Blaszard Looks like things have changed since 2016, don't see it now. Probably buried in a binary somewhere. May 7, 2020 at 4:51
  • So no way to solve the OP's question now?
    – Blaszard
    May 7, 2020 at 4:53

This is a little dated but someone appears to have written a guide:


If you have problems there seems to be some good tips for using Ukelele here:


  • Both links use Ukelele, which doesn't support Korean input. For example, trying to type "한" using a custom input source gives me ㅎㅏㄴ instead of the actual letter. Feb 15, 2016 at 4:30
  • Gotcha, sorry I missed that issue. I tried Tom's suggestion above and it doesn't work either. Would comment directly but this stupid 50 reputation limit :( Feb 15, 2016 at 4:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .