0

I use the English and Korean input sources on my Macbook.

For some reason or other, the English one has a U.S. flag as its icon, but the Korean one has a completely different icon — the letter "⬜" instead of the Korean flag. This really bugs me.

I've tried using the program Ukelele to make my own input source with the Korean flag as its icon, but apparently Ukelele doesn't support the Korean input method.

So is there a way to edit a preexisting input source? I'm looking to change the icon of the default Korean input source on the OS X.

EDIT: Apparently StackExchange thinks all Koreans must be spammers. The letter "⬜" (which has been replaced) looks like this: https://ko.wikipedia.org/wiki/%ED%95%9C

  • Regarding flags, Apple is gradually moving away from them where possible, presumably to "denationalize" keyboards which could be used in various countries. US Extended is now ABC Extended, and there is a plain ABC keyboard for those who prefer not to have the US flag present. – Tom Gewecke Feb 15 '16 at 4:22
  • I don't seem to have any problem posting 한 here. – Tom Gewecke Feb 15 '16 at 4:23
  • @TomGewecke Perhaps it's a reputation thing. When I try to type the letter, it tells me to "spam somewhere else." – user3932000 Feb 15 '16 at 4:28
1

Go to System/Library/Input Methods/KoreanIM.app and view its Package Contents/Contents/Resources. There you will see .pngs for the various Hangul IM's. Try replacing the relevant one of those and see if that does the trick.

0

This is a little dated but someone appears to have written a guide:

https://saltesta.com/hack/customizing-mac-input-source-icon/

If you have problems there seems to be some good tips for using Ukelele here:

https://superuser.com/questions/665494/how-to-make-a-custom-keyboard-layout-in-macos

  • Both links use Ukelele, which doesn't support Korean input. For example, trying to type "한" using a custom input source gives me ㅎㅏㄴ instead of the actual letter. – user3932000 Feb 15 '16 at 4:30
  • Gotcha, sorry I missed that issue. I tried Tom's suggestion above and it doesn't work either. Would comment directly but this stupid 50 reputation limit :( – Todd Dabney Feb 15 '16 at 4:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .