I recently attempted to open the App Store application iFlicks and received the following error message.

error message

Unfortunately, this application has been removed from the App Store so I am unable to download it again. I have gone back through my Time Machine restoring different versions from different years but they all provide the same message.

My question, has anyone encountered this problem and, if so, how did you go about fixing the application? Further, how can this be fixed if the application has been removed from the App Store?

  • Have you recent changed OS versions?
    – JMY1000
    Feb 15, 2016 at 2:46
  • No, I am still running OS X Snow Leopard (one of the reasons I can't upgrade to iFlicks 2). The last time this application worked was in October. Since then the application has not been updated and nothing has changed on my computer.
    – Ghost Koi
    Feb 15, 2016 at 2:50
  • Have you tried creating an external volume and doing a full restore to it from that version of time machine?
    – JMY1000
    Feb 15, 2016 at 4:26

2 Answers 2


Download the Mac OS X Snow Leopard Update.

Apple released an "App Store" Update for Mac OS X Snow Leopard users on January 27th, 2016. This update appears to handle new certificate changes that will render out-dated apps "damaged." Downloading and installing this update should solve the problem.

This is the link to manually update the software from Apple's website.


The Snow Leopard update should fix the problem. The issue involves expired security certificates in the App Store. This was a big issue a couple months ago. Ordinarily, people could just delete and re-download the app...In your case, since this is not possible, install the latest fix for Snow Leopard and that should fix your issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .