Sometimes when I want to delete a line of text very quickly I do this:

I hold the shift key and press the arrow up key to select the line above and then I press backspace. But occasionally I press all three keys at the same time which deletes the line too but creates a hidden control character with the value 08: the value for the backspace control character.

This can be pretty annoying e.g. if you are writing code and you can't figure out what causes the parse error.

Am I the only one who struggles with this from time to time? Is it possible to change this behavior?

  • I can't seem to reproduce this. I'm using a MacBook Pro (built-in keyboard) on Lion. Obviously I'm testing it in Chrome, and I tried in MacVim too. (1) What is your hardware setup? (2) Which app(s?) can you do this in? Aug 21, 2011 at 19:04
  • Can't reproduce either
    – Alexander
    Aug 21, 2011 at 19:18
  • It doesn't seem to work in Chrome. I guess they disabled control characters. Try it in the search field in Safari. The X icon will appear, which proofs that there is invisible text.
    – Lenar Hoyt
    Aug 21, 2011 at 19:28
  • Is "backspace" what my keyboard calls "delete"?
    – GEdgar
    Aug 21, 2011 at 22:02
  • en.wikipedia.org/wiki/Backspace
    – Lenar Hoyt
    Aug 22, 2011 at 8:31

1 Answer 1


I can't reproduce this either. However, I suggest that you hold down Command and then press Delete, as an alternative to your method. This will delete everything on the line that's left of the cursor, and will hopefully solve your problem. (You can hold down Option to delete single words. Experiment with holding down the Option or Command key, and pressing either Delete or the arrow keys. If you hold down Shift with either Option or Command and then press the arrow keys, you will be able to select text word by word, or line by line.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .