I'm not sure what happened but I used to be able to backup to a drive shared with a networked Mac Mini using OSX server. Now all of a sudden it says there is not enough space.

So I reformatted the drive (12TB) and restarted the whole thing. However Time Machine now tell me there is not enough space. It says:

The backup disk needs 5.35 TB for the backup but only 499.49 GB are available.

I'm not sure why only 499GB is available.


3 Answers 3


I've run into this before when using networked backup, also said something like 497GiB were free when actually 4TiB were free. Seems this is caused by TM not creating a large enough sparsebundle for the initial backup. I found a workaround that at least worked for me (El Capitan) and submitted a bug report to Apple.

Workaround: You should notice that the sparsebundle on the OS X server has only ~499GiB as its capacity. Manually enlarge it by running this command on the server: sudo hdiutil resize -size [number of gigabytes]g [path to sparsebundle], e.g. sudo hdiutil resize -size 10000g /Volumes/Backups/mybackup.sparsebundle. Make it as large as you need. Retry your backup.

Edit: You may also have to resize the sparsebundle's partition in Disk Utility. I didn't have to do this, but maybe that's because my backup wasn't encrypted. For instructions, see the first (not accepted) answer here: Increase size of sparsebundle for TimeMachine


It sounds like you may not have the correct drive selected for the Time Machine backup. Can you try temporarily turning off Time Machine in the System Preferences and then choose Select Backup Disk on the right and choose the 12TB disk. This will verify you're attempting to use the correct disk.

Alternately you may need to check that the new disk is formatted correctly using the steps at the beginning of this doc:



I had the same problem, so maybe my experience will be helpful.

I have a 24TB ThunderBay RAID hooked up to my iMac and although there was enough space on my separate Time Machine HD (via USB), it gave me a warning that I needed over 2.5TB of extra space for a Time Machine backup of 120GB.

After reformatting the TM-HD, I finally unmounted the ThunderBay RAID, then switched it off and removed the Thunderbolt connection from the iMac. Only then did the TM backup to the Time Machine HD immediately work without a hitch.

Maybe something in the TM prefs got severely confused by having the RAID hooked up, but for me this solved the problem.

  • +1 for ejecting the HDD after reformatting it and trying to use it for Time Machine. Plugged it back in and no longer get the error.
    – pkamb
    Commented Aug 4, 2018 at 1:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .