0

I have a macbook pro mid 2012 and recently I upgraded it by changing the RAM to 16GB and HDD to 500GB SSD. It was fine for a while but now it lags a lot whenever I play any games or even when I am normally using it. I did Memory and Hard drive test and both of them were fine. I even replaced my RAM because I read it somewhere that I should replace my RAM when these things happen, but still the problem occurs.

While upgrading my Hard drive I cloned my old hard drive and then transferred that to the SSD, I don't know if that's what causing the problem.

  • Have you checked Activity Monitor for what might be slowing you down when this occurs? – JMY1000 Feb 13 '16 at 23:34
  • My memory usage is around 4 GB and the CPU Load is also fine. I don't see any problem in there. Before this problem occurred I also installed XAMPP, do you think if that caused the problem? but, I have removed it a while ago. – Akshay Singh Feb 13 '16 at 23:51
  • Strange, is it always fine even when your computer appears to slow down? That doesn't seem to make sense. – JMY1000 Feb 13 '16 at 23:53
  • Yes and my Memory Usage is always between 3-4 GB, even if i run a big program. I don't know why that happens.. – Akshay Singh Feb 14 '16 at 0:00
0

You also can try re-instal the osx using the: cmd+r at the start, see this video: https://youtu.be/vxSbpZAIGm8 , Isn't mine, this can help you

  • For some hours it was working great but now it has started again. I am tired of this.. – Akshay Singh Feb 14 '16 at 23:45
  • I have readed about the RAM, i think the 16 gbs force the cpu, have you tryed with 12 gb RAM? I have the same Macbook Pro, and i have 8 gbs RAM without problems – Kanata Feb 15 '16 at 0:02
  • No I have not, but my friend has the same mac as mine and even he has the 16GB RAM and his is working fine – Akshay Singh Feb 15 '16 at 0:49
  • Have you tryed the recent comment? About the trim enabler? – Kanata Feb 15 '16 at 0:51
  • yes i have, still no improvement – Akshay Singh Feb 15 '16 at 2:06
1
  1. If you run Yosemite or El Capitan, enable the native OS X trim support with the Terminal command : sudo trimforce enable, followed by a restart.
  2. For older OS X versions try the TRIM enabler from Cindori Software.
  • I have tried the trimforce enable, still not happening – Akshay Singh Feb 14 '16 at 23:46
0

Try cloning the disk, try a clean install, using a external volume.

  • I was going to do that but I don't have the HDD with me right now.. – Akshay Singh Feb 14 '16 at 0:23
0

I have your same hardware (macbook and ssd) and the problem was the sata cable of notebook.

For me surprise, I dont pay nothing to fix it, even my notebook is out of guarantee, there is a recall from apple for this cable.

Go you to Apple Authorized service and good lucky !

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .