0

For years, I've had no problem with using on a Microsoft Sculpt Mobile Keyboard as well as a Microsoft Bluetooth Mobile Keyboard 5000. I'm using a late 2011 MacBook Pro, OSX El Capitan v.10.11.3, (Bluetooth 4.0).

problem:
Starting about 3 weeks ago, sometimes I'd press a letter key, I'd let go of the pressed key, but OSX seemed to sense I was still holding the key down. This problem happened with both those keyboards. This problem never occurred while using the attached keyboard.

Once the letter started uncontrollably repeating, I switched to the MacBook's attached keyboard. After about 1 second of frantically pressing esc while also using the trackpad to place the cursor behind the repeating text, the last character typed stopped repeating. I could continue typing on the Bluetooth keyboard as if nothing had happened. The problem would not occur again for days.

ideas:

  • This problem has coincided with my El Capitan upgrade.
  • This problem definitely happens to me while doing Japanese character input. I'm not 100% sure that this has also happened to me while doing English input.
  • El Capitan has added new features with regard to Japanese character input.
  • Of course, the keymappings for the 2 MSFT Bluetooth keyboards are far apart from the unique / weird MacBook keyboard layout. They sure don't have fn, control, option, command, ... and the command key is used for Japanese input.

So far, it has happened when I am typing in MSFT Word, MSFT Excel, a Chrome browser, and the NetBeans IDE. But not in any Apple apps.

But, it only happens infrequently. It is annoying, but not the end of the world. Maybe just buy an Apple keyboard.

  • Have you tried to "re-pair" your keyboard with your computer? – Darkstar Feb 13 '16 at 23:00
  • @Darkstar yep. i've repaired the keyboards a few times. – konishiki Feb 13 '16 at 23:25
  • Which Japanese IM are you using, Hiragana? Direct Kana or Romaja? All apps including TextEdit, Mail, Safari, Message, Notes, or only some apps? (this info should ideally all be in your question) – Tom Gewecke Feb 13 '16 at 23:56
  • @TomGewecke Once I change to Jp input ("command" + "spacebar") on an Apple keyboard, i start typing in hiragana, and sometimes it goes nuts. For ex, while typing "にゅうりょく" sometimes "ゅ" won't stop repeating. The "Live Conversion" feature was added to El Capitan. Maybe this problem is related. But, I keep it turned-off. I don't like it. – konishiki Feb 14 '16 at 0:39
  • @TomGewecke What I mean is that changing to Jp input on one of the MSFT keyboards is "Alt + spacebar" (which is equivalent to "command + spacebar" on a mac keyboard). MSFT keyboards don't have a "command" key. I only use hiragana and katakana input. Anyway, maybe I just have pizza crumbs under both keyboards. – konishiki Feb 14 '16 at 1:58
0

Regarding the shortcut for changing input sources, in El Capitan it is Control plus Space (unless your upgrade process carried over Command plus Space from an earlier OS version). Normally the MSFT Windows key = Apple's Command key. Alt = Option.

  • This problem just happened while typing in English in NetBeans. I give-up. I'd like to close this thread. – konishiki Feb 15 '16 at 1:15
  • Also, I very much appreciate your taking an interest in this weird problem that is surely only happening to me. – konishiki Feb 15 '16 at 1:20
0

a good solution is to use this app: https://github.com/Aahung/Unshaky Hope this helps

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .