0

I have a work Macbook Pro and do not want to use iMessages.app at all to sync to my phone. When I open up the Messages application on my iPhone, Continuity tries to handoff the application to the OSX machine on the same wifi. However, I want to completely disable iMessages.app syncing to this computer. iMessages.app Continuity Popup

I have disabled:

(On iPhone)->Settings->Phone-'Calls on other Devices' [Off]

(On MBP)->iMessages.app-> No Accounts setup

Is there a way to disable this iMessages Continuity integration?

1

If you want to disable iMessage to be synced with your iPhone:

  • On iPhone --> Settings > Messages > Text Message Forwarding > Remove your MBP device that should appear.
  • On MBP --> No account setups is ok (double check if your iCloud account has already been disabled).

Finally, you can definitively get rid of Handoff by unchecking "Handoff" in iPhone > Settings > General > Handoff & Suggested Apps.

  • Thank you. It was the 'Handoff' setting on the phone, which seems to be a proxy for 'Continuity Enabled'. I turned that off and all application handoffs are disabled via continuity. – tmarthal Feb 12 '16 at 21:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .