1

I'm having terrible issues with my Mac since I tried to restore the entire system from a Time Machine backup, which ended up showing a "an error occurred while adding a recovery system to the destination disk" message. I restarted and held cmd+R and Internet Recovery started downloading (instead of booting to the recovery partition). After the download, the menu of OS X utilities appeared and I selected Disk Utility and then I erased the Macintosh HD.

Tried to restore from Time Machine again but the problem persists. I even tried to reinstall OS X: after downloading OS X Mavericks, I got "an error occurred while preparing installation".

Here you can see the results of diskutil cs list and diskutil list commands:

[Terminal diskutil list[1]

As you can see, I have no CoreStorage Logical Volume Groups and I don't see the Recovery HD partition in disk0.

0

I do believe OS X Base System is the name of the mounted Recovery Partition image.

I would suggest completely erasing every last partition on your drive (except Recovery), recreating a Macintosh HD partition, and reinstalling OS X onto the newly partitioned Macintosh HD.

As for restoring your data, you can use Migration Assistant (/Applications/Utilities/Migration Assistant.app) to restore data from the Time Machine backup after you get a working system, or better, use the "Enter Time Machine" functionality from the TM menubar dropdown.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .