5

I recently changed my Gmail account's password. The account in Mail.app is offline as expected ("Login Failed"), but there seems no way to input the new password:

  • There is no password input field in Mail→Preferences→Accounts anymore. The fields Incoming Mail Server and Usernamecontain the right information, but they are greyed out (cannot be changed).
  • System Preferences→Internet Accounts: "Mail" is checked, but clicking on the "Details…" button only shows two editable fields: Description and Name.

I tried to force Mail.app/Internet accounts Prefs to ask for the new password by deleting the imap.gmail.com entries in Keychain.app, but it did nothing.

Where do I input the new password? Alternatively, how do I force Mail.app to ask for the new password? (A webview panel should popup, where I can input the password.)

Deleting and setting up my gmail account anew in Mail.app is not an option. I'm running OS X 10.11.3. Google 2FA is enabled.

  • 1
    Do you have two factor authentication set up on your gmail account? Do you have something like "enabled less secure applications" in your gmail settings? – Jon V Feb 10 '16 at 23:45
  • @JonV: I have 2FA enabled. I checked and the setting allowing "less secure applications" is not enabled. Here's what is says: "This setting is not available for accounts with 2-Step Verification enabled." – DBK Feb 11 '16 at 11:55
4

Go to Mail -> Preferences -> Accounts -> Accounts Information Tab and click Outgoing Mail Server drop-down menu. Select 'Edit SMTP Server List'

enter image description here

Click Advanced tab and in the Authentication field select 'Password'. Enter your new password in the according field.

enter image description here

Hope this help.

  • Thank you! This is only for SMTP (outgoing), not IMAP (incoming) though, right? – DBK Feb 11 '16 at 11:37
  • I stand corrected. Your suggestion forced the webview to appear! There I could insert my new password and authenticate with 2FA. This solved my problem. – DBK Feb 11 '16 at 12:02
  • I have had something similar on a friend's Mac with an AOL account as well—where changing the password for incoming had no effect, but dropping into the advanced SMTP settings did the trick. – samh Feb 11 '16 at 14:46
  • This doesn't work for me in Apple Mail 9.3 (10.11.6). user206758's suggestion did. – MiB Nov 24 '16 at 4:35
  • Thanks for this tutorial everything is so krptic on MAC now!! Thankful for the internet. – Carmen Aug 10 '17 at 19:27
3

An alternative way to force the mail application to ask for your password is to write a new email, send it to some test address (a friend maybe, or another account you have yourself, say an icloud account or a yahoo account etc.)

When you try to send it, the mail application should create a large "Google style" dialog box, a bit like you might see on a Google sign-in dialog on a typical Google web service such as YouTube.

Enter the password there; it will be cached somewhere internal, so it should keep working. No idea where it gets stored.

This works with my Gmail account that is set up in IMAP. I assume this is the result of that accounts menu option "Automatically detect and maintain account settings".

  • 1
    Yeah, this worked when all else failed. – MiB Nov 24 '16 at 4:35
2

A late post. But, I thought of sharing a simple solution that worked for me. Instead of Mail --> Preferences, going to Mail --> Accounts and clicking on the failed gmail account will launch a popup with a password box and correct password input will login successfully.

  • This works - a simple solution which is what it should be! Come on Apple, this stuff should be easy, not requiring ages browsing to find out what to do. – SomaMan Jun 28 '17 at 10:13
1

I would say go to Mail -> Preferences -> Gmail -> Advanced. There is a box labeled "Automatically detect and maintain account settings". Uncheck it. You should now be able to edit the respective fields (including password.) However, this seems to be greyed out for me as well, so I'm not sure.

I'm not sure if this will work, but try it.

Go to Mail -> Preferences -> Gmail -> Account Information -> Outgoing Mail Server (SMTP) -> Edit SMTP Server List... Under authentication add some form (I'd try password first).

To check if this worked, go to Window -> Connection Doctor and make sure everyone is green and happy.

  • "However, this seems to be greyed out for me as well, so I'm not sure." For me as well :( – DBK Feb 11 '16 at 11:38
  • Your second suggestion worked. But I accepted the other answer because it had nice screenshots :) – DBK Feb 11 '16 at 12:03
  • @DBK Glad I could help :) – JMY1000 Feb 11 '16 at 15:30

You must log in to answer this question.

protected by Community Aug 10 '17 at 21:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .