4

I have a MacBook Pro (17-inch, Late 2011) with OS X El Capitan. I just installed the trial version of Parallels Desktop 11.1.2 for Mac Business Edition, Parallels tools, and Windows 7 x32 bit in english.

The resolution of my Mac is 1920*1200. I have set the resolution of Windows to be 1600*1000 to occupy the whole screen. The problem is everything in Windows (e.g., fonts, texts, images) looks a little bit blurry, at least not as clear as Mac. This does not change with other resolution of Windows.

Does anyone know how to fix this problem?

PS: after 1 hour looking at the blurry Windows, I feel already dizzy...

Edit 1: I take two screenshots (one from Mac, the other one from Windows; both of them under 1920*1200) to show the difference:

enter image description here enter image description here

  • The pictures look identical to me. That suggests that Parallels is interpolating the identical images to a lower resolution within the Windows guest. – Jon V Feb 10 '16 at 23:51
  • If you open them each in a browser tab, and look at for exemple the titles "Overview", "What's New", "Ressources", you could see the difference. We don't see such a difference with VMWare or VirtualBox (which have other defaults unfortunately). – SoftTimur Feb 11 '16 at 9:47
  • Ah - this may just be a difference in the way Chrome on Mac (the first picture) renders things vs. Chrome on Windows (the second one). I notice that the default fonts are slightly different between Mac and Windows (I have both) when I view the same pages on Chrome on Windows vs. Mac. – Jon V Feb 12 '16 at 14:36
  • Aaaaaand now I read the second part which is "looks the same on VMWare or VirtualBox". So scratch my comment. – Jon V Feb 12 '16 at 14:59
3

You shouldn't be setting the resolution of Windows in Parallels.

Boot Windows and choose Virtual Machine → Install Parallels Tools and follow the instructions. This sets the resolution automatically according to the window dimensions.

If Parallels Tools doesn't set the right resolution in full screen, in Configuration set Full Screen: Scale to fit screen to Auto.

  • in Configuration it is already "Auto", and the resolution is set automatically 1024*768, which is not good... – SoftTimur Feb 10 '16 at 21:50
1

Apparently, this is caused by Windows somehow not being well "adapted" to the high DPI of Apple's Retina displays. The problem is described (and a solution given) in the Parallels Knowledge Base at http://kb.parallels.com/en/114700, but both the Knowledge Base article and the other answer here are slightly out of date at present, so I thought I'd provide my own answer. This is what worked for me, but some menus may be slightly different for you.

  1. Launch your Windows VM in Parallels.
  2. Click Actions in the top menu bar of your VM window (may be called Virtual Machine in some versions of Parallels)
  3. Click Configure in the dropdown menu
  4. Click Hardware in the top menu bar of the configuration menu
  5. Click Graphics in the left sidebar (may be called Video in some versions of Parallels)
  6. Select the Best for Retina display radio button (may instead be an Enable Retina resolution checkbox in some versions of Parallels)

You'll be prompted to restart your VM, and then the blur should be gone.

In case you can't find them in your UI, all the things I had to click are circled in the screenshots below:

First image

Second image

  • While your answer may be true for Retina displays, the OP's MBP is a non-Retina device (MacBook Pro 17-inch, Late 2011)! – klanomath Apr 27 '17 at 14:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .