I've upgraded to Lion today and since then I am facing a very strange problem.

  • Gmail, Facebook, discussions.apple.com do not load at all, and IF they loaded, I get only text with no CSS or images.
  • support.apple.com, Google, apple.stackexchange.com work fine and astonishingly fast, as usual
  • The sites which do not load, do not load in Chrome and Safari, but if I used wget I do get immediately the HTML of the page.

This may suggest (if anything at all) that the mechanism wget is using works fine but the mechanism Chrome and Safari are using is not fine. Does this make any sense to you ?

I've tried searching Google.com (since it loads fast enough), and I get to see the results only through Google cache (because accessing them directly won't work!), and what I found is that lots of people are having this speed problem (and other problems as well).

However, apart from Apple, I am curios to to know why could wget access sites which Chrome and Safari can't ?

Edit: I confirm that Facebook works from Lynx (a terminal-based browser) but doesn't work on Chrome nor Safari.

Edit2: I can even load facebook quickly through a proxy, though I can't load it directly!

Edit3: apple.se loads on Chrome but doesn't load on Safari.

  • 1
    Instead of adding "[SOLVED]" to the title, please simply accept the answer that answered your question. Commented Aug 21, 2011 at 13:28

2 Answers 2


Try renaming /Library/Preferences/SystemConfiguration to /Library/Preferences/SystemConfiguration_Backup and restart your computer. I've had some really strange issues where the network .plists that are stored in SystemConfiguration have caused problems.

If it doesn't resolve the issue just delete the folder and set the SystemConfiguration_Backup back to its original name.

The folder houses config files for some system services, but when you restart it will create new copies of these files.

  • Thank you. I actually just removed preferences.plist, not the entire folder. Now everything works :) ! Commented Aug 21, 2011 at 5:28

Try resetting the PRAM and NVRAM with the instructions here and let us know if that fixes that problem.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .