Used to be able to print like a charm. It's a network printer. Now all I get is: Hold for Authentication screendump

When checking the system log all it says is:

09/02/16 12:24:41,669 NetAuthSysAgent[42720]: NAHSelectionAcquireCredential Error Domain=com.apple.NetworkAuthenticationHelper Code=-1765328228 "acquire_kerberos failed username@LOCAL: -1765328228 - unable to reach any KDC in realm LOCAL, tried 0 KDCs" UserInfo={NSDescription=acquire_kerberos failed username@LOCAL: -1765328228 - unable to reach any KDC in realm LOCAL, tried 0 KDCs}

There shouldn't be anything kerberos related with this printer.

Anyone know of a fix or workaround?

  • 1
    The printer or print server is now requiring a password. It may be that you are required to be logged into the local network or that the print server or printer has its own password. Commented Feb 9, 2016 at 12:49
  • Deleting and re-adding the printer does resolve the problem, but only temporarily. I'm on a laptop which I dock at work, where the problem printer is located. When I leave and then return to work, I find the issue has returned. It's not that my credentials keep expiring. I will try to add the printer using guest credentials to see if that approach has staying power.
    – Lee Reed
    Commented Jun 22, 2020 at 14:37

4 Answers 4


the problem could be also related to storing a wrong password in the Key Chain Access; Go-->utilities--> Keychain access search for the printer and then update the password.

  • this only works if the prompt showed up to enter network credentials. the problem is that OSX later versions do absolutely nothing!
    – MC9000
    Commented Apr 20, 2021 at 22:26

Have same issue with one user. Click on reload button and you will be prompted for password (it is domain password). Also removing computer and adding computer to domain and reinstalling printer helps.


I found this post via a Google search. I have an HP Officejet 4510 g510n-z and strangely enough, resetting (https://h30434.www3.hp.com/t5/Inkjet-Printing/OfficeJet-4500/m-p/585875/highlight/false#M548340) the printer solved the issue I had with continual 'Hold for Authentication' messages I had with sharing a Windows printer (via built in Windows 10 x64 printer sharing) and attempting to print with OS X Mojave.

The symptom was that even after authenticating with the local admin account (which is a Microsoft.com account, with my e-mail address/password) I would continually be prompted for the login/the local print status in Mojave would yield 'Hold for Authentication'. Attempting to use the 'Guest' login would yield the same outcome - continual 'Hold for Authentication' / no successful print.

Resetting the Printer solved the issue - I re-added the printer in Mojave, and clicked 'Guest' and can print successfully.

Bizarre, I would have never thought that resetting the printer would solve a network/domain authentication problem.

Good luck!


No passwords involved here at all. Just deleting the printer job with the "Hold for authentication" error, removing the printer from "Apple - System Preferences - Printers & Scanners" and adding it again fixed it in macOS 10.15.3 (19D76) Catalina.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .