2

UPDATE: I figured out in part what is happening, but not why or how to change this behavior. When at the computer itself, Finder only activates the screen you are on when you click on the desktop(Finder) or a window on that screen. All other Finder screens are inactive. When connected via VNC or ARD/ScreenSharing only the first screen becomes active even if that screen was not the active one when you first connected. If another screen was active at the time you connect it becomes inactive and the first becomes active the first click that occurs. It is like the first screen has occupied all screen spaces.

ORIGINAL POST As I mentioned in a previous question, I have a MacPro with 6 DVI monitors. We'd like to remotely manage it when necessary via Screen Sharing but it appears that only the first screen/display is actually controllable even though the content from all of the displays is visible. The menu bar is greyed out on all except the first screen and none of the apps are responsive.

This occurs both with the Apple Screen Sharing as well as via VNC. Both are enabled via Remote Management as opposed to Screen Sharing.

Is there a way to activate the rest of the desktops? On the rest of the laptops around the office with monitors and only two displays, this lockout does not occur.

  • The toolbar at the top of the screen sharing app should have a dropdown or button to select which monitor you want to control. Are you not seeing this? – Hefewe1zen Feb 8 '16 at 23:19
  • Even when selecting a different display (as opposed to all), the menu bar continues to remain greyed out and none of the programs within that screen are workable. I've checked through several versions of Mac OS X as well (10.8 through 10.11) to see if it was a version OS incompatibility. – dcmbrown Feb 9 '16 at 14:41
2

Alright. The issue is a stupid one which is not entirely evident. When setting up a Mac with this many screens, be careful with the arrangement. When arranged all in a row, even a 1 pixel overlap will cause the overlapped screen to take over all of the others and cause the behavior I stated above. It is not evident from the desktop. On a gut feeling I ended up dragging all of the screens around to make sure they were entirely aligned and as far over as possible from the previous screen. It turned out the first screen was the slightest bit overlapping the second.

I'll leave this question/answer up for anyone else who might encounter this bizarre issue.

  • I've been fighting this issue for a while when connecting to my iMac Pro at work! Rearranging the displays (to exactly the same layout) seems to have fixed it. Thanks! – Jason Floyd Oct 11 '18 at 1:38
0

I took note of the display alignment and made sure that the 2nd screen (I only have 2 on the iMac) was accurately aligned and close up to the first. This solved my problem which was that when performing screen sharing, the second display was always black.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .