Very often an exFAT external disk stops appearing in OS X. It doesn't appear in Disk Utility, Finder, diskutil list or About this Mac/System Report/USB.

The only way I have found to fix it is to boot into Windows and run the standard 'Scan disk for errors' function that pops up on connecting the drive. It never finds any errors. The disk then appears fine in OS X again.

Is there a way I can run this repair in OS X? It seems it is just a flag, possibly to indicate the drive was unplugged without first being ejected.

  • 1
    As I mentioned on the original post on SO, I think OS X might actually be running this check silently in the background, there's just no visual indication it is doing this (if it's a spinning drive, you might hear it). I've long wondered about this myself though, so I'm hoping for some definitive information. Feb 8, 2016 at 7:09
  • Sorry @Alexander I meant to ask you to re-post here so I could up-vote your comment. Next time my disk disappears I'll wait longer and report back. If this is true I believe it is only if the drive is connected after OS X is started. If it is connected during start-up in this state my drive light flashes in an error state. If I connect it after start-up the light is constant, which could mean it is doing the fix as you suggest.
    – Chris
    Feb 8, 2016 at 15:03
  • This might be related apple.stackexchange.com/questions/270850/…
    – William
    Jan 29, 2017 at 23:26

2 Answers 2


I've been having the same problem with my 128GB thumb drive. Turns out, it just takes a while (10-15m) for it to appear in Disk Utility, almost certainly on account of its size. Running First Aid after that gives me no errors (though it takes a similar amount of time to run). Try waiting longer next time, and avoid disconnecting the drive without ejecting first.

  • I've finally seen this behaviour. Oddly the disk light was flashing during the check, which usually means error, and which usually only happens if I turn the laptop on with the disk already connected, which I didn't this time. I can't stand this function - I know very well that no files were open and often the disk disconnects if the USB cable is nudged slightly, so it is usually pointless to thrash the disk like this. Didn't happen on Windows.. I'd love to know a way of overriding this, some utility that marks a 'faulty' disk as not faulty - it is just some flag somewhere.
    – Chris
    Feb 25, 2016 at 17:45
  • I've posted asking how to prevent his scan here as this is quickly killing my disk and I want the option like in Windows to dismiss the check.
    – Chris
    Mar 11, 2016 at 22:22

Same problem here, took a few minutes to load the external drive, but after a long (and tense) time, it finally loaded.

My conclusion is that the problem are the not emptied trash files. The drive was working just fine, then I had to delete a lot of files and ejected it without emptying the trash. Next time it was not loading, so I tried in a different MacBook, tried Disk Utility First Aid, tried other solutions found on the internet but nothing worked. After reading the answer here I plugged it and wait a few minutes and it loaded. Then I emptied the trash and everything was back on tracks.

Hope it helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .